Home

Question: No Image when turned on


marym Author

You can see here how much reputation marym has received from other members.

Apprentice Traveler
Replies: 0

21 May 2011, 16:38

I purchased two XXL's in December for Christmas Gifts.  I really like the product but have been experiencing some glitches for several months. The screen is NOT going on or goes on and then shuts down.  Someone mentioned that the connection from cable to device sometimes goes bad.  Please advise.

  • sallor225

    You can see here how much reputation sallor225 has received from other members.

    Exalted Voyager
    Replies: 2205
    Expert (Car navigation)

    Expert (Car navigation)

    7 June 2011, 16:03

    Don't know how your question got to be two weeks old.

     

    First make sure the battery is charged. When it is connected a little green light should be on. Charge for at least 2 hrs. with the device off. Make sure your cigarette lighter plug is still intact; sometimes they start to unscrew causing a poor connection.

     

    Second, if that does not help. Try resetting your device by holding down the on button untill you hear the double drum roll (15-20 seconds). Restart.

     

    Third, if that does not help make sure you have the latest version of Home (go the Help/Update Home). Then connect your device to your computer, turn on, say yes to connect, then go to "Operate My Device" and navigate to some point, add or deleat a POI, safely disconnect your device (Device/Disconnect Device; wait for message "OK to Safely Disconnect"). Restart device and see if that helps.

  • Jarod

    You can see here how much reputation Jarod has received from other members.

    Apprentice Traveler
    Replies: 1

    27 July 2012, 02:40

    Hi,

     

    I directed myself to this forum as I have had the same problem and have tried everything (charging for >2 hours, updating, hard reset, navigating to a point and safely disconnecting) and I still just have sound and no images. I received my XXL last summer and it has been working fine up until this past week as one day I turned it on, saw my intro image that I downloaded, and suddenly the screen went black and have been unable to visualize anything but a blank screen since. If you could let me know what would be the best course of action at this point I would really appreciate it. Thanks

  • theresa363

    You can see here how much reputation theresa363 has received from other members.

    Neophyte Traveler
    Replies: 3

    27 July 2012, 06:13

    i am having sort of the same problem i brought mine feb of last year hardly used it yet when i tried to use it the screen was just blank all you can hear is some type of sound last week , i just tried it and  a blue back ground with the picture of the tom tom is showing  it wont do nothing all day someone please help!!

  • dhn
    dhn

    You can see here how much reputation dhn has received from other members.

    Exalted Vanguard
    Replies: 13678
    Expert (Car navigation)

    Expert (Car navigation)

    27 July 2012, 12:57

    Have you tried resetting the device by holding the power button about 15 seconds till you hear the drum sounds (unless your device has a dedicated reset hole on the bottom).

  • theresa363

    You can see here how much reputation theresa363 has received from other members.

    Neophyte Traveler
    Replies: 3

    27 July 2012, 16:27

    i personally have hot the reset button  still nothing

  • theresa363

    You can see here how much reputation theresa363 has received from other members.

    Neophyte Traveler
    Replies: 3

    27 July 2012, 16:31

     i also tried to up date it and is getting i need to format disk drive error message

Reply to this post

Uploading in progress:
0%
Browse
Add
If the URL is correct, a preview will appear here. It can take a few minutes for larger images to show.
  • :D
  • :?
  • :cool:
  • :S
  • :(
  • :@
  • :$
  • :8
  • :)
  • :P
  • ;)
View mobile version
Powered by Insided