Home

Question: MY TOMTOM XL WON'T SWITCH ON


MARIA_55_55 Author

You can see here how much reputation MARIA_55_55 has received from other members.

Apprentice Traveler
Replies: 1

11 March 2012, 00:25

My Tom Tom XL has suddenly decided not to work. I have connected it to the computer and the green light is on therefore it seems to be charging but when I press the switch on button nothing happens.

any suggestion would be very much appreciated

thanks

38 comments

  • Wyvern46

    You can see here how much reputation Wyvern46 has received from other members.

    Exalted Navigator
    Replies: 481

    11 March 2012, 00:29

    First thing to do is a reset.

  • MARIA_55_55 Author

    You can see here how much reputation MARIA_55_55 has received from other members.

    Apprentice Traveler
    Replies: 1

    11 March 2012, 00:37

    it won't reset when I press the switch on button which is also the reset button, nothing happens at all

  • muffinski

    You can see here how much reputation muffinski has received from other members.

    Apprentice Traveler
    Replies: 1

    11 March 2012, 16:30

    You have to keep the reset button on for at least 20 seconds. If a funny screen comes up, press the button again (no need to hold). It worked for me!

  • martslaw

    You can see here how much reputation martslaw has received from other members.

    Apprentice Traveler
    Replies: 1

    14 March 2012, 21:59

    Hi can anyone help me,my tomtom xl routes edition will not turn on,red light is on but nothing happening. Where is the reset button? Many thanks Martin

  • Traylaw

    You can see here how much reputation Traylaw has received from other members.

    Elite Voyager
    Replies: 3675

    15 March 2012, 00:31

    Here is a link which will tell you how to reset your gps..... When you select your model it will display the procedure for your model.

     

    http://us.support.tomtom.com/app/answers/detail/a_id/7134

  • docomoyo

    You can see here how much reputation docomoyo has received from other members.

    Apprentice Traveler
    Replies: 1

    7 July 2012, 13:47

    Excellent!

     

    My TomTom Packed up last night when I stopped off at Newport Pagnell Services, it just wouldn't switch on. The Amber and Green light came on but nothing more.  As Suggested I held the button down for 20 seconds this morning and hey presto, it came back to life and I didn't lose anything such as stored addresses and setting.

     

    Thank you for posting this on here it has been very useful indeed.

     

  • Magsofessesx

    You can see here how much reputation Magsofessesx has received from other members.

    Apprentice Traveler
    Replies: 2

    16 August 2012, 09:30

    Help!

     

    My tom tom 510 wont switch on! I only used it a few days ago and it was fine, I have rest it using the pin and holding the on/off button the green light comes on but it still doesn't switch on! I have a few map problems with it too but don't want to update it as last time I done so I lost the ability to search fro postcodes!

     

    Any help gratefully appreciated!

     

    Mags

  • dhn
    dhn

    You can see here how much reputation dhn has received from other members.

    Exalted Vanguard
    Replies: 14205
    Expert (Car navigation)

    Expert (Car navigation)

    16 August 2012, 12:58

    Is the battery fully charged??

  • Magsofessesx

    You can see here how much reputation Magsofessesx has received from other members.

    Apprentice Traveler
    Replies: 2

    16 August 2012, 16:09

    Yes I have plugged it into the power and it has come back on. It had a full charge the last time i uded it how could the battery die so quick? unless it turned itself on? also the maps still appear out of date and it wont let me use an external device to access live?
  • Moonmaedyn

    You can see here how much reputation Moonmaedyn has received from other members.

    Apprentice Traveler
    Replies: 1

    20 August 2012, 04:05

    Mine is doing the same thing...I turn it on and you can hear the "TOMTOM" music, but the screen won't light up. I know the screen does NOT have issues, as when this happened, I connected it to the computer and the screen came on and I was asked if I wanted to connect to the computer. I tried the "reset" thing and still do not get a picture on the screen. I have had this unit less than a year. Should I return it to TOMTOM or what? Most annoying to have it just go kaput like this...

  • Predtor_XL350TM

    You can see here how much reputation Predtor_XL350TM has received from other members.

    Renowned Wayfarer
    Replies: 105

    20 August 2012, 06:16

    if after soft or hard reset device doesnt work, seems that next step is to contact tomtom representative..

  • Sus22

    You can see here how much reputation Sus22 has received from other members.

    Apprentice Traveler
    Replies: 1

    31 August 2012, 22:13

    I have a TomTom One and it is playing up, wont switch on, then does switch oh when it feels like it.  Tried reset, still wont do anything, only first screen appears.

     

    Trying to get it attached to computer, "does not recognise device" - new USB cable never been used.

  • robcarberry

    You can see here how much reputation robcarberry has received from other members.

    Supreme Navigator
    Replies: 119

    1 September 2012, 00:25

    What PC application are you using to connect your tomtom to your PC?  It should be the Tomtom Home v2.9.1  You can down load it here.

     

    You can download TomTom Home here http://www.tomtom.com/services/service.php?id=16&tab=87&Lid=1

     

  • WeatherWiFi

    You can see here how much reputation WeatherWiFi has received from other members.

    Outstanding Explorer
    Replies: 13

    1 September 2012, 01:14

    My XL335 only Flashes a Red X when turned on, just started this today, just a Flashing Red X!

    Yesterday worked Great, Today its a Piece of Junk!

    Won't Reset after Pressing the Reset Button!

    Won't Connect to PC or TomTomHome!

    Can't get any immediate Help from anyone at TomTom!

    My XL335 is just over 1 year old, I guess 1 year is its total life span.

     

    My XL335 is used everyday, on all the time, only shutdown when I park the truck. This morning I was looking into a new Garmin GPS, because I can't find a fix for the TomTom! My Unit has been sitting here flashing Red X for hours off charge, battery still not dead.

     

    Any Help would be appreciated!

  • robcarberry

    You can see here how much reputation robcarberry has received from other members.

    Supreme Navigator
    Replies: 119

    1 September 2012, 01:38

    Does your PC recognize the connection to your PC at all?  Does it show up as a drive in windows explorer so that you can then run a chkdsk on it?

     

     

    See if this link will help you get your device connected to your PC http://us.support.tomtom.com/app/answers/detail/a_id/7394/kw/red%20x

     

    and this link might help you get rid if the red x  http://us.support.tomtom.com/app/answers/detail/a_id/2053/kw/red%20x

     

     

  • WeatherWiFi

    You can see here how much reputation WeatherWiFi has received from other members.

    Outstanding Explorer
    Replies: 13

    1 September 2012, 02:41

    XL335 - I decided to get off the Laptop with Win 7 Pro, I installed TomTomHOME to my Windows XP Pro Desktop. I turned on my XL335 and plugged the Data cable to the PC and XL335. My Desktop Found New Hardware as an External Storage Device and asked me to Format Drive D: Message Popup. My TomTomHOME says Device Not Connected. My XL335 Unit is still Flashing the Red X Screen.

     

    1. Press On

    2. Flashing Red X Screen

    3. Download/Install TomTom HOME to Windows 7 Laptop and Windows XP Desktop

    4. Found New Hardware as a Storage Device, Please Format Drive D: Message appears

    5. TomTomHOME Device Not Connected

    6. Still Flashing Red X Screen

  • tomdodds1

    You can see here how much reputation tomdodds1 has received from other members.

    Apprentice Traveler
    Replies: 1

    5 September 2012, 22:32

    My TOMTOM XXL wont start, the green charging light has been on i have pressed the button for 20 seconds, plugged into my computer and still nothing please help!

  • mart2008

    You can see here how much reputation mart2008 has received from other members.

    Apprentice Traveler
    Replies: 1

    6 September 2012, 08:53

    I had the same problem with my Go710 and came across a helpfull hint that sorted mine out. Although you place the unit onto the dock to charge it and the light comes on, it does'nt necessarily mean that the unit is charging. If you apply some pressure to the unit to hold it down onto the dock/charger, then try and switch it on, it should work. Try it, it might sort your's out as it did mine. 

  • Jason75

    You can see here how much reputation Jason75 has received from other members.

    Outstanding Wayfarer
    Replies: 55

    7 September 2012, 22:59

    In my computer, can you right click on the icon that represents the external storage device and hit explore. That should get you inside the storage drive so you can get a look at what is there. If you can see maps and such, make a complete copy of the drive in explorer. If you can effect a copy, all is not lost. I would run a chkdsk command on the GPS to test for and correct any file corruption. If I tried to reboot - I would recommend holding the start button down for up to 30 second. You may get a diagnostic screen or a plain yellow green colored screen.

     

    In about 50-70 percent of these flashing red x cases, it is the result of a corrupted Navcore (which is the OS for the GPS).The x is telling you the GPS cant find the OS. If you can check for errors and or copy file, you can likely save it

     

    But I have seen more and more of the hard drives in these units going south. That also gives you the flashing red X because the end result is the same, you just took a slightly different route to get there. I gave this advice to another poster. The most expensive component in your used unit is your screen (it worth about $30.)  Buy a used one matching your specs (and which will boot up) with a broken screen off ebay.  Transfer your screen to that unit and you are back in business for not much money. $5-$10 at the most. Takes about 10 minutes and its intuitive.

     

    I would follow the advice of the mods here who favor testing all of the avenues before you throw in the towel.

     

     

  • WeatherWiFi

    You can see here how much reputation WeatherWiFi has received from other members.

    Outstanding Explorer
    Replies: 13

    8 September 2012, 18:01

    Connected GPS Unit to PC, low and behold, after switching on the unit I get a Please wait Screen (First Time, didn't get the Drum Roll and Flashing Red X Screen), but the unit is still not working properly!

     

    I right click storage drive and hit explore and get this message: The Disk in Drive (E) is not Formatted, would you like to format it? Yes or No, I chose: No!

     

    In drive E: Properties, Tools, Check Disk, Start Now, Nothing Happened!

     

    In drive E: Properties, General, Used Space: 0 bytes, Free Space: 0 bytes, Capacity: 0 bytes, File System: Raw

     

    In drive E: Tools, Defragment Now, Starts, Stops at Message: Disk Defragmenter cannot run on this colume type.

     

    In drive E: Tools, Backup Now, Drive E: Message Appears: The drive E: did not respond, please make sure there is a valid disk in the drive to function properly.

     

    In drive E: Properties, Hardware, drive E: TomTom One, Type Disk Drive, Device Status: this device is working properly.

     

    In drive E: Properties, hardware, drive E: TomTom One, Properties, Volumes, Populate, Volume E: 1908 MB, Disk: 3, Type: Removable, Staus: Online, Partition: MBR, Capacity: 1908 MB, Unalicated Space: 0 MB, Reserved Space: 0 MB.

    Here it shows something is on the GPS Unit, but it won't let me explore the units drive or do any tools.

     

    Start: My Computer, Manage, Disk Management, drive E: removable, 1.86 GB, Healthy, Right Click, Explore, Message Appears: Please Format Drive: E.

     

    Start: My Computer, Manage, Removable Storage, Media: Name: 1, Type: Removable, Library: TomTom One, State: Idle, Mounted Side: 1, Usage: New

    Libraries: ATAPI iHAP422-9 and ATAPI iHDP118-4 and TomTom One

     

    This is all I can do to my XL335 GPS Unit, It only accesses Computer as a Removable Drive and won't let me in to view any files unless I Format it. MyTomTomHOME still says Device Not Detected!

     

    I have done these Explorations on both Windows XP Pro SP3 Desktop and my Windows 7 Pro Laptop.

     

    ANY OTHER IDEAS?

  • robcarberry

    You can see here how much reputation robcarberry has received from other members.

    Supreme Navigator
    Replies: 119

    8 September 2012, 20:27

    1)  Have you tried running the clear flash tool 3 times also?  http://us.support.tomtom.com/app/answers/detail/a_id/7394/kw/clear%20flash%20tool%203%20times/related/1

     

    2)  Was your unit backed up prior to this that you can maybe reformat it and then restore from backup?

     

    This link below describes how to do it.  But I should warn you that it says 

     

    Important: Follow this procedure only when you have been advised to by TomTom Customer Support, or if you have an active Map Update Service subscription.

     

    So you might want to contact customer service first.  

     

    To me I'm logically thinking that you can connect your device and Windows shows it as connected and ready to use but you can not see any file content.  You get the same result on two separate PC's.  It seems to me the problem is related to device file system.  You are not able to run a chkdsk, and nothing changes after trying to run the clear flash tool 3 times.  

     

     

    http://us.support.tomtom.com/app/answers/detail/a_id/15940/kw/format

  • WeatherWiFi

    You can see here how much reputation WeatherWiFi has received from other members.

    Outstanding Explorer
    Replies: 13

    9 September 2012, 16:52

    I downloaded the TomTom Flash Tool, Followed Instructions, step by step as it says.

    Flash Tool refuses to Install and will not Detect the GPS Unit drive: E. on Windows XP Pro SP3 with IE8

    Flash Tool refuses to install and will not Detect the GPS Unit drive: D. on Windows 7 Pro with IE9

     

    I tried Step by Step Instructions to Install

    I tried Unzipping the Downloaded File and Double Clicking Install TomTom Flash Tool also, with no Luck, Still won't install!

     

    I have a Reset Button on the Bottom of my Unit, I pressed the Reset Button and all I get is the Black Screen with Info and Credits about my Unit in White Lettering.

     

    Here is what it says after Reset Button pressed:

     

    TomTom One (TM) (c) TomTom 2003-2010 Build -N/A-

    Hardware Type: TomTom XL

    SubID (Feature) 0 1: 00 (0000000D0000000)

    Bootloader version: S5.5274 clist#540743 RUCT

    Checksum: 5D04

    Memory: 64 MB Type: MDDR

    CPU ID: 32450003

    Clocks: 264.0 132.0 66.0

    GPS type: GL2 BCM4750 FFFF

    TFT Type: Samsung LMS430HF29 26

    Internal FLASH capacity: 1953792 KB

    MMC NAND version (PRV): 12 48.0 MHz 4 B Samsung

    Startup Mode: Sleep

    Device ID: GJ2430B10147

    Touchscreen calib. data: 212 826 325 660 @3300mV

    Sector protection: Yes

    Battery boot voltage: 5000 mV 0x036E 0x0300

    RTC: 14:50:28 09/09/2012

     

    Any More Ideas would be Appreciated?

  • WeatherWiFi

    You can see here how much reputation WeatherWiFi has received from other members.

    Outstanding Explorer
    Replies: 13

    9 September 2012, 17:15

     

    These following Discussions are what Ive achieved since my TomTom XL335 decided to stop working properly 2 weeks ago. These Discussions are in order from the Start to Current.

     

    Any other suggestions would be appreciated?

     

    I have a TomTom XL335, It was working fine yesterday, holding a good charge. Today my XL335 I turned it on and it shows a Flashing Red X onscreen, Will not show map! I brought it in the house, signed into TomTomHome on the Computer, I connected my XL335 with the Data Cable and turned it on to the Flashing X Screen and immediatelly my computer is asking to Format XL335 Drive. I chose to Cancel. My computer does not recognize the XL335 and will not Connect. I pressed the Reset Button next to the DataPort and nothing happened, just shut off unit. I restarted the XL335 and a new screen came up, it was information or credits to the XL335 Unit, but PC still wont recognize it. I shut it off and back on and the Flashing Red X returns and PC wants to format the unit.

     

    1. Flashing Red X Screen

    2. Info or Credits Screen

    3. Please Format XL335 Drive

    4. No PC Connection Recognized

    5. Will Not Connect to TomTomHome

    6. Stuck on Flashing Red X Screen

    7. Reset Button does not work

    8. Power Button held for 20 seconds shows info or credits about the unit

    9. Uninstalled TomTomHome, Reinstalled TomTomHome, No Change!

     

    I already searched the Forum and tried all current answers with no help!

     

    My unit is just over 1 year old (XL335).

     

    XL335 - I took my unit over to a different PC that has Windows XP Pro SP3, I downloaded and installed TomTomHOME to the Desktop. I turned on my XL335 to the Flashing Red X Screen, Plugged in the Data Cable to the Unit and PC, my Computer said New Harware Found, installed New Hardware as a Storage Device Only!

     

    I signed into TomTomHOME, it said Device Not Connected!

     

    I still have the Flashing Red X Screen, I can shut down the unit by pressing the Reset button on the bottom of the unit or the power button, but when I press reset and then hold the power button down for 20 seconds I get a different screen that shows information about the XL335, like credits on a screen.

     

    I tried to download and install TomTom Flash Utility, but it only works unless your XL335 is Connected to a PC, which this is the problem, my GPS XL335 refuses to connect to any PC XP or WIN7.

     

    My XL335 is just over 1 Year Old, I guess its the Total Life Span of the GPS Unit. XL335 has worked Flawlessly since the day I bought it and since the last update was installed. I never had any problems out of it till yesterday morning when it started Flashing a Red X instead of going straight to the the Map.

     

     I already tried several links from other forums, but I have to PC Connection, only recognized as a Storage Device and PC wants to Format it!

     

    Ok, I connected XL335 to my Computer, I accessed my TomTom Account online with IE8, Device not Detected.

    I opened TomTomHOME also, Device Not Detected!

     

    I access my computer, my computer says: Removable Disk: (E) 0 bytes, my computer keeps asking me to Format Removable Disk (E), won't let me access any files!

     

    On my TomTom XL335 when I connected it to the PC by USB Data Cable, I first had the Flashing Red X Screen, then it changed to Please wait Screen, now I'm seeing a Blue Screen with a picture of my unit and a cable out the bottom.

     

    I tried to Explore the Drive, won't allow access to unit, just keeps saying Please Format!

     

    Under Device Manager, Disk Drives, I see TomTom One, Microsoft says Device Working, it tells me which USB port its connected too and properties says 0MB.

     

    I tried to Access Unit through Disk Management, there's no access point available!

     

    Kind of Strange, one day it works Great, the next day it Don't work at all!

     

    My XL335 only Flashes a Red X when turned on, just started this today, just a Flashing Red X!

     

    Yesterday worked Great, Today its a Piece of Junk!

    Won't Reset after Pressing the Reset Button!

    Won't Connect to PC or TomTomHome!

    Can't get any immediate Help from anyone at TomTom!

    My XL335 is just over 1 year old, I guess 1 year is its total life span.

     

    My XL335 is used everyday, on all the time, only shutdown when I park the truck. This morning I was looking into a new Garmin GPS, because I can't find a fix for the TomTom! My Unit has been sitting here flashing Red X for hours off charge, battery still not dead.

     

    XL335 - I decided to get off the Laptop with Win 7 Pro, I installed TomTomHOME to my Windows XP Pro Desktop. I turned on my XL335 and plugged the Data cable to the PC and XL335. My Desktop Found New Hardware as an External Storage Device and asked me to Format Drive D: Message Popup. My TomTomHOME says Device Not Connected. My XL335 Unit is still Flashing the Red X Screen.

     

    1. Press On

    2. Flashing Red X Screen

    3. Download/Install TomTom HOME to Windows 7 Laptop and Windows XP Desktop

    4. Found New Hardware as a Storage Device, Please Format Drive D: Message appears

    5. TomTomHOME Device Not Connected

    6. Still Flashing Red X Screen

     

    Connected GPS Unit to PC, low and behold, after switching on the unit I get a Please wait Screen (First Time, didn't get the Drum Roll and Flashing Red X Screen), but the unit is still not working properly!

     

    I right click storage drive and hit explore and get this message: The Disk in Drive (E) is not Formatted, would you like to format it? Yes or No, I chose: No!

     

    In drive E: Properties, Tools, Check Disk, Start Now, Nothing Happened!

     

    In drive E: Properties, General, Used Space: 0 bytes, Free Space: 0 bytes, Capacity: 0 bytes, File System: Raw

     

    In drive E: Tools, Defragment Now, Starts, Stops at Message: Disk Defragmenter cannot run on this colume type.

     

    In drive E: Tools, Backup Now, Drive E: Message Appears: The drive E: did not respond, please make sure there is a valid disk in the drive to function properly.

     

    In drive E: Properties, Hardware, drive E: TomTom One, Type Disk Drive, Device Status: this device is working properly.

     

    In drive E: Properties, hardware, drive E: TomTom One, Properties, Volumes, Populate, Volume E: 1908 MB, Disk: 3, Type: Removable, Staus: Online, Partition: MBR, Capacity: 1908 MB, Unalicated Space: 0 MB, Reserved Space: 0 MB.

    Here it shows something is on the GPS Unit, but it won't let me explore the units drive or do any tools.

     

    Start: My Computer, Manage, Disk Management, drive E: removable, 1.86 GB, Healthy, Right Click, Explore, Message Appears: Please Format Drive: E.

     

    Start: My Computer, Manage, Removable Storage, Media: Name: 1, Type: Removable, Library: TomTom One, State: Idle, Mounted Side: 1, Usage: New

    Libraries: ATAPI iHAP422-9 and ATAPI iHDP118-4 and TomTom One

     

    This is all I can do to my XL335 GPS Unit, It only accesses Computer as a Removable Drive and won't let me in to view any files unless I Format it. MyTomTomHOME still says Device Not Detected!

     

    I have done these Explorations on both Windows XP Pro SP3 Desktop and my Windows 7 Pro Laptop.

     

    I downloaded the TomTom Flash Tool, Followed Instructions, step by step as it says.

    Flash Tool refuses to Install and will not Detect the GPS Unit drive: E. on Windows XP Pro SP3 with IE8

    Flash Tool refuses to install and will not Detect the GPS Unit drive: D. on Windows 7 Pro with IE9

     

    I tried Step by Step Instructions to Install

    I tried Unzipping the Downloaded File and Double Clicking Install TomTom Flash Tool also, with no Luck, Still won't install!

     

    I have a Reset Button on the Bottom of my Unit, I pressed the Reset Button and all I get is the Black Screen with Info and Credits about my Unit in White Lettering.

     

    Here is what it says after Reset Button pressed:

     

    TomTom One (TM) (c) TomTom 2003-2010 Build -N/A-

    Hardware Type: TomTom XL

    SubID (Feature) 0 1: 00 (0000000D0000000)

    Bootloader version: S5.5274 clist#540743 RUCT

    Checksum: 5D04

    Memory: 64 MB Type: MDDR

    CPU ID: 32450003

    Clocks: 264.0 132.0 66.0

    GPS type: GL2 BCM4750 FFFF

    TFT Type: Samsung LMS430HF29 26

    Internal FLASH capacity: 1953792 KB

    MMC NAND version (PRV): 12 48.0 MHz 4 B Samsung

    Startup Mode: Sleep

    Device ID: GJ2430B10147

    Touchscreen calib. data: 212 826 325 660 @3300mV

    Sector protection: Yes

    Battery boot voltage: 5000 mV 0x036E 0x0300

    RTC: 14:50:28 09/09/2012

     

    Any More Ideas would be Appreciated?

     

  • WeatherWiFi

    You can see here how much reputation WeatherWiFi has received from other members.

    Outstanding Explorer
    Replies: 13

    9 September 2012, 17:38

    I'm so fed-up with this TomTom XL335, I'm just about ready to take a Sledge hammer to it and go buy a GARMIN!

     

    Works Great one day, the next day it doesn't!

     

    I guess 1 Year is it's Total Life Span! Which SUCKS!

     

    My last TomTom before I upgraded to this one lasted me 7 Years, and it had a Memory Card that you can pull anytime and exchange out.

     

    Thanks for all the replies everyone, I really appreciated it! WE TRIED!

     

    NOTE: My unit XL335, was being used 16 hrs a Day, everyday for 1 Year. It stayed on it's mount, in my vehicle and was never removed 99% of the time, only once for an updated Map, which was no problem connecting, backup and upgrades. It shut down 2 weeks ago and has never worked since! TomTom Models today must be Junk, their nothing like the Models made 8 years ago. External Memory cards were the Best and better than these onboard internal Memory cards that can't be removed or replaced.

     

    I'm just Frustrated with TomTom, I have to tell someone!

     

     

  • Jason75

    You can see here how much reputation Jason75 has received from other members.

    Outstanding Wayfarer
    Replies: 55

    10 September 2012, 16:53

    Aside from having a bad USB cord, or a faulty USB port, sounds like the unit's HDD has gone south. You have done all that I can see you should try to do. You obviously cannot back up your unit if you can't access the hard drive to copy the files. Buy a working unit with a cracked screen, swap it out, and you'll be good to go. The only tools you will need is either a T4 or T5 torx screwdriver to remove the two screws under the label across the unit's underside, and guitar pick to ease the faceplate away from the body.. Gently pry the faceplate off and the screen should tip forward from top to bottom. You will see the video cable attached to the motherboard with a white clip on a dark connector. Side the white locking clip forward about 1/32 of an inch. The cable will release. Reverse the process to assemble and you will be back in bidness. Takes under a minute if you know your way around. Probably five -10 minutes max if you don't.

Jump to top

Reply to this post

Uploading in progress:
0%
Browse
Add
If the URL is correct, a preview will appear here. It can take a few minutes for larger images to show.
  • :D
  • :?
  • :cool:
  • :S
  • :(
  • :@
  • :$
  • :8
  • :)
  • :P
  • ;)
View mobile version
Powered by Insided