Home

Question: Error calling method on NPObject!


wd9dui Author

You can see here how much reputation wd9dui has received from other members.

Master Explorer
Replies: 5

15 August 2011, 20:09

This error has showed up a number of times, I have removed and installed TomTom Home from the Windows 7 machine.

I am using a

Name = TomTom XLS IQ Routes Edition

Device Code = AKSGCAAN4A

 

I get this error after doing the updates and opening "Operate my One XL"

 

ERROR: Error: Error calling method on NPObject!

in chrome://tthome/content/ui/subtask/emulator/emulatorPage.js:232

Stack:

0. function startup_navigator("RU3400B02438","9-061-576030-1.dll","40","TTU","G:") unknown

1. function () chrome://tthome/content/ui/subtask/emulator/emulatorPage.js:232

dataFolder);

2. function ([object XML]) chrome://tthome/content/ui/subtask/emulator/emulatorPage.js:148

this.initEmulator();

3. function ([object XML]) chrome://tthome/content/logic/util.js:79

return func.apply(obj, arguments);

4. function () chrome://tthome/content/logic/comm.js:442

this.successCallback(this.resultXML);

5. function (true) chrome://tthome/content/logic/comm.js:430

this._doneCallbacks();

6. function ([object ProgressEvent]) chrome://tthome/content/logic/comm.js:277

this.request.onload = function() { me._done(true); }

Time: Sat, 13 Aug 2011 23:16:23 GMT

 

 

  • dhn
    dhn

    You can see here how much reputation dhn has received from other members.

    Exalted Vanguard
    Replies: 14185
    Expert (Car navigation)

    Expert (Car navigation)

    15 August 2011, 22:42

  • wd9dui Author

    You can see here how much reputation wd9dui has received from other members.

    Master Explorer
    Replies: 5

    15 August 2011, 23:27

    Nice try, pretty general, what is the error stating? I have a call in and was put on hold a few times... Not resolved.

    Gary


    dhn wrote:

    See 2.b in this link:

    http://uk.support.tomtom.com/app/answers/detail/a_id/9863/?locale=en_GB


     

  • Traylaw

    You can see here how much reputation Traylaw has received from other members.

    Elite Voyager
    Replies: 3675

    16 August 2011, 02:43

    Only  TomTom's "Wizards of One's and Zero's" know.....and they don't answer emails and phone calls from lowly earthlings.

    I have a few inquiry's somewhere out there waiting for the one's on high to answer... 

     

    KT4F

  • paullewis

    You can see here how much reputation paullewis has received from other members.

    Apprentice Traveler
    Replies: 1

    25 March 2012, 21:33

  • wfj1952

    You can see here how much reputation wfj1952 has received from other members.

    Legendary Explorer
    Replies: 6

    18 May 2012, 01:24

    What is meant by:

    Your Windows username contains special characters.
    When you click Operate my device, HOME responds with the error Fatal Error -9000. This is because your Windows user name and/or profile folder(s) contain special characters, for example, å è ï ó ü ç ñ. These special characters cause Operate my device to respond with an error in the latest version of HOME.

     

    I have no special characters. What is meant by crating a new windows account?

  • MiB8888

    You can see here how much reputation MiB8888 has received from other members.

    Apprentice Traveler
    Replies: 1

    18 November 2012, 11:24

    The bug is present ~5 years already. Maybe its time for TomTom to hire developers that actually have some expertise on the chrome / xulrunner platform they use. It should not be *that* difficult to map character sets from UTF-8 to Windows-1252 and vice versa in a Java program... MiB, not a happy customer
  • bobschrade

    You can see here how much reputation bobschrade has received from other members.

    Apprentice Traveler
    Replies: 1

    12 October 2013, 18:38

    Here is what worked for me, using Windows 7. TomTom says this is the problem: "When you click Operate my device, HOME responds with the error Fatal Error -9000. This is because your Windows user name and/or profile folder(s) contain special characters, for example, å è ï ó ü ç ñ."  After taking their advice and changing my user name (where I log on each time I reboot my PC) from Daddy (note: no unusual characters!) to Hello, it still did not work - so obviously the problem was not, as TomTom claimed, anything having to do with special or nonspecial characters in my user name. So I went to Start and hit the option for switching users, and I switched to guest user. Then I connected my TomTom XXL, opened TomTom Home, and the update page said I should download a"One-time Update". I did, and it took awhile. But it worked! No longer a message about "Error calling method on NPObject!" Still dos not work back on my usual user account though, so I guess whenever I want to use TomTom Home I will have to switch users. A pain. Come on,TomTom, fix this after years of making everyone wait!

  • wd9dui Author

    You can see here how much reputation wd9dui has received from other members.

    Master Explorer
    Replies: 5

    15 October 2013, 18:47

    Well it appears the problems is no longer, I suspect that over the numbers of down loads, they pushed something to fix the issue.???? I think that this may have been fixed months ago. I hope that you all no longer have the same issue.
    Gary

  • khark

    You can see here how much reputation khark has received from other members.

    Master Explorer
    Replies: 5

    3 November 2013, 20:46

    It may have been solved for some people but not for me!!

  • JC2
    JC2

    You can see here how much reputation JC2 has received from other members.

    Apprentice Traveler
    Replies: 1

    13 December 2013, 14:08

    I have been experiencing this problem for at least 5 years. I found a reply several years ago that works, i.e. will fix the problem until the next update is applied. Here is the basic procedure:

    1. Backup all files and folders from your TOMTOM.

    2. Delete all files off the root directory of your TomTom DO NOT delete any FOLDERS.

    3. Disconnect device, reset it, then reconnect it.

    4. Reinstall all the software...and you're done.

     

    This was posted back in December 2011. Hope it helps someone.

  • poulladehoff

    You can see here how much reputation poulladehoff has received from other members.

    Master Explorer
    Replies: 5

    29 January 2014, 22:48

    Neither for mee too.

  • mvl
    mvl
    Revered Voyager
    Replies: 1894

    30 January 2014, 07:34

    The following two steps seem to have the most success in resolving the npobjects issue for most customers:


    1) Go to windowsupdate, and accept all optional and critical updates to microsoft dotnet


    2) reset Tomtom HOME, following the steps at www.tomtom.com/10059.  Note that this will require you to re-enter your Tomtom email/password into Tomtom HOME.

    I am a moderator at tomtomforums.com, an independent community of Tomtom customers. I am a Tomtom customer, not an employee.
  • poulladehoff

    You can see here how much reputation poulladehoff has received from other members.

    Master Explorer
    Replies: 5

    30 January 2014, 22:10

    Thank You for your advice. I have followed your suggestions and the program works now without any error messages.  I have the suspicion, that a cleaning program Systemic Mechanic is corrupting the file, that is downloaded to manage  the TomTom GO 930 from the PC, when I am using System Mechanic. I will contact their support to find out how to avoid that-

    Yours Poul Ladehoff

  • poulladehoff

    You can see here how much reputation poulladehoff has received from other members.

    Master Explorer
    Replies: 5

    31 January 2014, 12:55

    Do you know where the file that is downloaded to manage the The TomTom is situated? If I know that, I could exclude it from the "correction" in System Mechanic. It is not situated in the TomTom map in the registry.
    Yours Poul Ladehoff
  • mvl
    mvl
    Revered Voyager
    Replies: 1894

    2 February 2014, 14:18

    got to start -> run, then type %appdata% omtom


     


    That is a shortcut to the folder, but specific location it differs per OS version/configuration.

    I am a moderator at tomtomforums.com, an independent community of Tomtom customers. I am a Tomtom customer, not an employee.
  • khark

    You can see here how much reputation khark has received from other members.

    Master Explorer
    Replies: 5

    20 June 2014, 20:49

    Is this error ever going to be fixed. They have been promising a fix for years?

  • poulladehoff

    You can see here how much reputation poulladehoff has received from other members.

    Master Explorer
    Replies: 5

    21 June 2014, 10:22

     

     

    I do not think, that the company will do anything. It is perhaps too timeconsuming and costy. They want us to by a new model instead!I

  • john1945

    You can see here how much reputation john1945 has received from other members.

    Apprentice Traveler
    Replies: 2

    25 July 2014, 04:35

    I also am told I use special characters but I do not. Is it responding to the @ character in an e-mail address?

  • john1945

    You can see here how much reputation john1945 has received from other members.

    Apprentice Traveler
    Replies: 2

    25 July 2014, 04:35

    Is the problem the @ character in an e-mail address?
  • dhn
    dhn

    You can see here how much reputation dhn has received from other members.

    Exalted Vanguard
    Replies: 14185
    Expert (Car navigation)

    Expert (Car navigation)

    25 July 2014, 13:15

    Get the freeware version of Revo Uninstaller from here:


    http://www.revouninstaller.com/revo_uninstaller_free_download.html


     


    Completely uninstall Home 2.


     


    Get a fresh copy at tomtom.com/home

  • ait10101

    You can see here how much reputation ait10101 has received from other members.

    Apprentice Traveler
    Replies: 1

    7 September 2014, 14:24

    orked, but I did not need to delete downloads folder under Documents.

  • poulladehoff

    You can see here how much reputation poulladehoff has received from other members.

    Master Explorer
    Replies: 5

    9 September 2014, 19:03

    I tried the Revo-program. It was good for removing some rests in other programs, but the problem with Error calling method on NPObject was not solved using the proposed method.

    Yours Poul Ladehoff

  • MikkoKMikkoK

    You can see here how much reputation MikkoK has received from other members.

    Staff
    Replies: 6647
    Expert (Multi-sport)

    Expert (Multi-sport)

    Expert (Runner)

    Expert (Runner)

    Expert (Golfer)

    Expert (Golfer)

    Expert (Android App)

    Expert (Android App)

    Expert (iPhone App)

    Expert (iPhone App)

    Expert (RIDER)

    Expert (RIDER)

    Expert (Car navigation)

    Expert (Car navigation)

    12 September 2014, 12:50

    Help others identify useful content: - Did someone answer your question? Click Mark as Solution - Did someone post something helpful? Click the kudos button - Need help with your TomTom device? Add details about the TomTom device to your post: Device name, Application- and Map version.

Reply to this post

Uploading in progress:
0%
Browse
Add
If the URL is correct, a preview will appear here. It can take a few minutes for larger images to show.
  • :D
  • :?
  • :cool:
  • :S
  • :(
  • :@
  • :$
  • :8
  • :)
  • :P
  • ;)
View mobile version
Powered by Insided