Home

Solved: black screen


rocbianco Author

You can see here how much reputation rocbianco has received from other members.

Master Explorer
Replies: 4

7 April 2011, 04:29

After I set my address setting in my XL, after 30 seconds my screen goes black.  But the XL still provides navigation.

Why does the screen go black?

Marked as answer: Lorna on 29 April 2011, 10:23

Hi,


 


That's perfect - thank you!


 


Tap on Change preferences in the menu then on Brightness preferences.  On the first screen (day and night colour preferences) tap on Done and you will see a screen called Battery saving preferences - tap on Never turn off screen.


 


That should fix it :)


 


You will get a second Battery saving preferences screen - Switch off when external power is lost - that probably isn't affecting this but you can untick it if you want to be sure.


 


Thanks,


Lorna

View original comment
  • LornaLorna

    You can see here how much reputation Lorna has received from other members.

    TomTom Employee
    Replies: 208

    21 April 2011, 15:00

    Hi,


     


    It sounds as though you may have a battery saving preference selected.  Tap on Change Preferences and then on Battery Saving Preferences - untick the option to dim the screen between instructions.


     


    Does the screen stay on now?


     


    Thanks,
    Lorna

  • rocbianco Author

    You can see here how much reputation rocbianco has received from other members.

    Master Explorer
    Replies: 4

    22 April 2011, 03:28

    Lorna, I do not have the "battery saving" option on my gps.

    What else can I check?

  • LornaLorna

    You can see here how much reputation Lorna has received from other members.

    TomTom Employee
    Replies: 208

    22 April 2011, 09:37

    Hi,


     


    Which XL do you have?  The easiest way to know is to give me the first 2 digits of the serial number, which is on the bottom of the device by the barcode.


     


    Thanks,


    Lorna

  • mikealder

    You can see here how much reputation mikealder has received from other members.

    Revered Navigator
    Replies: 236

    23 April 2011, 11:07

    Go to change preferences/ Safety Preferences and make sure the checkbox for "Hide map above a certain speed" is turned OFF.

    Otherwise Change Preferences/ Battery Preferences and deselect the checkbox for turn off screen between instructions - Mike

  • rocbianco Author

    You can see here how much reputation rocbianco has received from other members.

    Master Explorer
    Replies: 4

    24 April 2011, 03:34

    Lorna:

     

    The first 2 digits of the serial number is 4E.

  • LornaLorna

    You can see here how much reputation Lorna has received from other members.

    TomTom Employee
    Replies: 208

    26 April 2011, 11:23

    Hi,


     


    Sorry - that's not the serial number - it starts with a letter --- often is syas C/NO: or S/N: just before it.  It's a long number - about 10 digits long.


     


    Thanks,


    Lorna

  • rocbianco Author

    You can see here how much reputation rocbianco has received from other members.

    Master Explorer
    Replies: 4

    29 April 2011, 00:12

    Lorna:

     

    The first 2 digits are RB.

    Hope this helps.

    Thanks for all your help.

  • dhn
    dhn

    You can see here how much reputation dhn has received from other members.

    Exalted Vanguard
    Replies: 13723
    Expert (Car navigation)

    Expert (Car navigation)

    29 April 2011, 01:37

    Tomtom sees the unit as: XL (30 Series) / 330 - 1GB

  • LornaLorna Answer

    You can see here how much reputation Lorna has received from other members.

    TomTom Employee
    Replies: 208

    29 April 2011, 10:23

    Hi,


     


    That's perfect - thank you!


     


    Tap on Change preferences in the menu then on Brightness preferences.  On the first screen (day and night colour preferences) tap on Done and you will see a screen called Battery saving preferences - tap on Never turn off screen.


     


    That should fix it :)


     


    You will get a second Battery saving preferences screen - Switch off when external power is lost - that probably isn't affecting this but you can untick it if you want to be sure.


     


    Thanks,


    Lorna

  • rocbianco Author

    You can see here how much reputation rocbianco has received from other members.

    Master Explorer
    Replies: 4

    3 May 2011, 02:25

    You're my hero Lorna.

    It worked.

    I got my TomTom working again.
    You're the best.

    Thank you.

  • Lazare

    You can see here how much reputation Lazare has received from other members.

    Apprentice Traveler
    Replies: 1

    30 January 2012, 17:59

    On my XL, most of the time my screen remains black (BUT with a very discreet sign of ON if you are in the night). So no way to do anything since there is nothing on the scrren.  But the XL still provides navigation because it indicates the Speed Cameras and speeding . I gave it back to the aftersales service but when they have the XL, everything was OK. When I got it back, it continues not to respond to the TURN ON button

    Why does the screen remain black?

  • dillybird

    You can see here how much reputation dillybird has received from other members.

    Apprentice Traveler
    Replies: 1

    10 November 2012, 03:50

    my tomtom was working fine then all of a sudden the screen went black and now it will do nothing

     

  • KRB
    KRB

    You can see here how much reputation KRB has received from other members.

    Apprentice Traveler
    Replies: 2

    5 March 2014, 17:50

    I have the same problem with my Rider 2nd edition. Have inserted a new battery, reset and reloaded soft ware but the screen still shows faint vertical lines and nothing else. I can see no detail. Only guess where conect to computer is.
  • kumo

    You can see here how much reputation kumo has received from other members.

    Revered Pioneer
    Replies: 872

    5 March 2014, 18:10


    KRB wrote:
    I have the same problem with my Rider 2nd edition. Have inserted a new battery, reset and reloaded soft ware but the screen still shows faint vertical lines and nothing else. I can see no detail. Only guess where conect to computer is.

    The flat wire of the LCD Assy may have been moved in the connector at the printed circuit board during replacement of the battery. Suggest to open the unit again and check all wires for proper fit.

    Rider 2nd, Rider 2013, VIA 125 Live, GO 1000 Live
  • KRB
    KRB

    You can see here how much reputation KRB has received from other members.

    Apprentice Traveler
    Replies: 2

    7 March 2014, 17:30

    Sorry for the delay in replying.  Did not want to check whilst having a cold and sneezing!   Have taken the unit apart and checked all wire connections which seem to be fully home.  My Rider unit only seems to have two wire conections - battery and rear case.   All back together but still a problem.  Push the on button and there is a very short but bright white light followed by a dark screen with vertical lines. It is receiving via gps as they move and if I connect to PC and touch the screen where I belive the connect button is then it does connect and up date. Would it be a soft ware problem?

     

    regards

     

    Keith

  • manlovej

    You can see here how much reputation manlovej has received from other members.

    Apprentice Traveler
    Replies: 1

    10 March 2014, 03:55

    i have a black screen with writing on it. trying to reset and down load my maps.

Reply to this post

Uploading in progress:
0%
Browse
Add
If the URL is correct, a preview will appear here. It can take a few minutes for larger images to show.
  • :D
  • :?
  • :cool:
  • :S
  • :(
  • :@
  • :$
  • :8
  • :)
  • :P
  • ;)
View mobile version
Powered by Insided