Home

Question: Battery problem?


Nkay11 Author

You can see here how much reputation Nkay11 has received from other members.

Legendary Explorer
Replies: 4

5 June 2011, 20:47

Hey guys, I bought my sat mac only a few weeks ago and haven't really used it much yet but I fully charged it the other day and went to use it yesterday but upon turning it on, it had very little battery. The bar was on yellow :/ I'd fully charged it prior to this so I'm just wondering if this could possibly be a faulty battery maybe?

Anyone else had any similar problems?

Thanks.
  • dhn
    dhn

    You can see here how much reputation dhn has received from other members.

    Exalted Vanguard
    Replies: 13715
    Expert (Car navigation)

    Expert (Car navigation)

    5 June 2011, 23:02

    That shouldn't happen on a brand new unit -- any model -- with a normal battery. You should expect at least an hour, maybe more of service before the battery poops out.

     

    That said, on some newer models, the battery will go yellow at the 45% level, to my understanding.

  • sallor225

    You can see here how much reputation sallor225 has received from other members.

    Exalted Voyager
    Replies: 2205
    Expert (Car navigation)

    Expert (Car navigation)

    6 June 2011, 03:15

    If you charged it while using it, your usage may have prevented from charging as quickly as you thought. They recommend a two hour minimum charge with unit off when connected to your computer. I suppose it would be about the some in the car. Mine was at about 45% charge and I charged it overnight. A couple of hours did not seem to bring it all the way up. Make sure it is truly connected by looking to make sure the little green light near the cord is on. Also, if connected to your computer, make sure it is not connected to the monitor or keyboard or a router, only one of the USB ports of the computer

  • Peggi

    You can see here how much reputation Peggi has received from other members.

    Apprentice Traveler
    Replies: 2

    6 June 2011, 03:43

    Hi, I have only used my xxl 550 several times since I purchased it in January.  I charged it up on a trip this week-end overnight with the cord to elec. outlet and it lasted only about 2 hours, Is that NORMAL?  I would have expected it to stay charged longer than 2 hours.  I do have a car charger but did not have it with me.  Thanks

  • sallor225

    You can see here how much reputation sallor225 has received from other members.

    Exalted Voyager
    Replies: 2205
    Expert (Car navigation)

    Expert (Car navigation)

    6 June 2011, 03:57

    That is right. I checked the specifications for your unit and they list 3 hours for autonomous use. Depending on how active the unit is during use it could certainly be less. It is better to always keep it plugged in while using. Also, if your unit has IQ Routes, with out the cable for the car you have no antenna for the IQ Routes.

  • Peggi

    You can see here how much reputation Peggi has received from other members.

    Apprentice Traveler
    Replies: 2

    6 June 2011, 04:29

    well, thanks.  I guess it is working ok.  I will just have to carry the cord with me.  Thanks ever so much.  Peggy

  • Nkay11 Author

    You can see here how much reputation Nkay11 has received from other members.

    Legendary Explorer
    Replies: 4

    6 June 2011, 14:16

    I fully charged mine last night overnight and turned it on this morning. I just left it on to see how long it would last and it's only lasted an hour and a half :/ that's without actually using it either so god knows how long it'll last if I was actually using it properly :/ after I turned it on from being charged overnight, it only showed that i had just below a full battery... I'm wondering whether it does just have a faulty battery?
  • sallor225

    You can see here how much reputation sallor225 has received from other members.

    Exalted Voyager
    Replies: 2205
    Expert (Car navigation)

    Expert (Car navigation)

    6 June 2011, 14:55

    If charging overnight and you get a reading of just below full battery; that sounds about right to me. An hour and a half sounds a little short. You might try contacting TTSupport to see if there is a problem. I would continue to use it (since you probably have a year warranty) but us it with the cord connected and monitor the battery level.

Reply to this post

Uploading in progress:
0%
Browse
Add
If the URL is correct, a preview will appear here. It can take a few minutes for larger images to show.
  • :D
  • :?
  • :cool:
  • :S
  • :(
  • :@
  • :$
  • :8
  • :)
  • :P
  • ;)
View mobile version
Powered by Insided