Question

iOS Connectivity with TomTom VIO


  • Apprentice Traveler
  • 1 reply
Have persevered with the tom tom VIO but on every journey I have used it the connection drops between the vio and iPhone, it is so unreliable that I regret buying it now, there appears to be no resolution to this issue, no updates to the app, which I am sure is the root of the issue, I close the app and then restart it and all is good for a while then drops again. Is there any future updates for this or have Tom Tom given up on it

8 replies

Userlevel 7
Badge +5
Hi Pajr,

Welcome to the Community!

This is a known issue unfortunately and we're working hard to find a fix as soon as possible. Some of the other users have been able to work around it by turning their phone to flight mode but leaving Bluetooth®️️ enabled.

Could you also state your iOS version and iPhone model, please so that I can add them to the ticket?

Cheers, lampard
Thank you for the reply and in answer to your questions, iOS 11 on iPhone 6S

Thanks
pajr
Is there any update to the lost connection issue?
Hello!

I have the same issue with my iPhone 7 and TomTom VIO, but only when the application is in the background. If I leave it in the foreground, it eats up my battery of course, but the connection stays stable.

Do you have any update on this issue? New workarounds? Planned software update?
Userlevel 2
Hi.

I have the iphone and also experienced some issues. If the gps does not have an active route, the ios will kill the app and the gps unit will only show a phone with a question mark. With an active route the app will stay on. Also i think that is ok to leave the app on foreground and just close the screen using power button.
From time to time the ios will kill the app regardless of the activity of the app.

On android the implementation is much better, has lots of options and one great feature is that with the phone on standby if you start the vio the app will automatically launch in the background, this way even if the phone will kill the app you would still be able to restart it.
I have the same problem! I hope in fix for that!
Similar issue (lost connection and a phone with a question mark) with my iPhone 6 and IOS 11.4. Unnaceptable!!! We have paid for a Product that doesn’t work ...
I have a 7 plus and my solution to this problem is to change the screen saver mode from "1 minute" to "NEVER"... This way the phone -and the VIO app- is always on; the connection does not die... I am lucky to have a usb charger on my bike so the battery is also not a problem...

Tomtom needs to find a better solution to this nerve braking problem. Like an update that makes the app connected while on the background or making it stay on the screen for the duration of the ride for example...

Reply

    Cookies

    At TomTom, we're all about helping you get around. That's why we use cookies to improve our sites, to offer information based on your interests and to interact with social media. If you're OK with this, you can continue using our sites. Allow Learn more or manage preferences

    Allow Cookie settings