Question

Errors when logging in -MyDrive ,TomTom Services and devices


Userlevel 5
  • Renowned Wayfarer
  • 126 replies
Yep got the same thing on my 6200, no traffic in the Nottingham area.

Good job I’m not going far today.

Tried soft reset 3 times so I assume it’s a Vodafone 2g issue.
This topic has been closed for comments

31 replies

Userlevel 5
Literally just come back at 8am!
Good morning.

The same thing happens to me. I have a TomTom Go 6200 and I am in Spain. Have if they solve the problem soon that we can not have the real traffic on our device.
Hi everybody,

I am unable to login to the MyDrive Connect software. I am entering the correct login credentials and just keep getting kicked back to the login screen.
I can not login @ mydrive for update; it seems to have trouble to recognize emailadresses?
Mine is the same. Just goes around in a loop. Also can't logon online.
Same thing also happens in Germany on my TomTom Go 5100 with software version 17.300.0018.311.

GPRS is connected, traffic information is activated, yet the symbol for traffic info shows no available information (and, trust me, there should be lots of info, as traffic was pretty bad today).

Also, I cannot login into MyDrive Connect. Entering the correct credentials just kicks me back to the login screen; wrong credentials will show a warning.

Hope this gets resolved soon!
Userlevel 6
Badge
Same problem with me in the southern M25 area. During a 1 hour journey this morning it briefly got a connection a couple of times, but other than that - nothing. A restart made no difference.

Throughout all of this the GPRS status was showing as connected, so I don't think it was a Vodafone problem.
Badge +5
Hi All,

This is a temporary outage wherein users are not able to login on MyDrive and also, unable to retrieve the traffic information on the device or App (cross on Traffic icon).

I'll keep you posted here once it is resolved.

Thanks, lampard
I have Tom Tom 5100 and have lifetime services. But now my device will not access services and keeps saying "Oops. We are having trouble accessing TomTom services. Please try later"
Well been having this for the past month so what is wrong?
I have tried resetting my device and still not working.
I have tried creating another account but still same message!
What the hell is going on Tom Tom and please do not ask me to reset as this is having no effect whatsoever.!!!
Also why won't it connect with my correct password... but it is quick to tell me my password is 'incorrect' if i purposely make an error!!!
So to me the services ARE working incognito because if they really were down they would not be able to tell my password is incorrect!
Sort it!
I keep getting stuck at the login screen despite keying in the correct password. I have no issues logging in via the webpage but i need to update the maps in my gps and i have cannot login via the Mydrive connect application. When I plug in my GPS to my laptop, it will auto-restore my GPS claiming that it has problems and the restoration keeps repeating itself.
Hi
Is anyone else having trouble with opening My Drive Connect.
Had an update and now I can not get past the splash screen at the start. it just hangs.
Reinstalled as well and still cannot open to allow me to update the Sat Nav.
In Denmark you can log into MyDrive Connect, - but unable to retrieve traffic information. This happens on a GO 5100.... Please fix!
jkevin wrote:

I'm having exactly the same issue after updating MyDrive Connect this morning. I also had some difficulty loging into my TomTom account on the web. Just got a blank page after loging in and had to manually refresh the page.
I wonder if it's an issue with their user authentication servers rather than a MyDrive connect problem.
Hopefully, TomTom might be monitoring and let us know soon.


In a way this makes me feel better as I have exactly the same problem and thought it was me.
Problem must be there end so I can stop trying to fix it here.
Also strange that for the first time Live Traffic was not working this Morning so hopefully they are aware and fixing it
Userlevel 7
Badge +3
Hi all

I have merged all the queries related to the login issues(MyDrive web/app, MyDrive Connect, Devices, TomTom Services) under one topic here.

As Lampard mentioned above we are having technical issues/outage which is causing this.

We apologie for the inconvenience caused and we are working hard to get this resolved as soon as possible.

Your patience will be appreciated.

I promise to post back here once there is an update to share.

Thank you
Vikram
No Traffic today on my 6100
My Drive Connect does not accept my password anymore.

Totally useless support from TomTom, time to re-evaluate my options

"Thank you for contacting TomTom Customer Care. Unfortunately we are unable to respond to any messages sent to this email address.

If you wish to contact TomTom Customer Care, go to https://uk.support.tomtom.com/app/contact./track/BvN4mwrkDv8a~bFNGhm_~yAj2OgqKy75Mv~3~zj~PP8_ Alternatively, have a look at our FAQs on https://uk.support.tomtom.com/app/results/track/BvN4mwrkDv8a~bFNGhm_~yAj2OgqKy75Mv~3~zj~PP8_ or our user forum TomTom Discussions (http://en.discussions.tomtom.com/) to find your solution. "

With Kind Regards

The TomTom Customer Care Team
I'm glad I'm not the only one with MyDrive problems. Yesterday I tried to make an update and my maps just got erased from my gps ... After that everything just bloked.
And of course today I can't even get into my account!!! It doesn't recognize my password and just refreshes the page.
It's so annoying that you don't even get a message from tomtom.
(Luxembourg)
Help - We are in Australia. Have just bought a map for another country and have not been able to download it to the computer. The purchase shows on our account but we did not get the email confirmation. Then we tried to install MyDrive Connect and it won't let us log in at all. It says underneath to register an account with TomTom which of course we already did. Are we supposed to register another account or what? We have already spent hours trying to figure this out and going around in circles. Worst webpages and customer service I have ever encountered. What is going on? We are going overseas in a few days and need this extra map installed on our TomTom urgently.
If i type mailadres and password, and i connect, the boxes are blanc again. This sucks, do something about it. Also, i cannot view my account on this site, is there something wrong with the server AGAIN?
Had the same problem.

Delete MyDrive Connect and reinstall (takes a couple of minutes).

All now working fine.

Seems that TT screwed somthing up as a 'routine maintenance' screen flash briefly.
Userlevel 7
@AussieMal

Contact Customer Services to check the status of your order (as they have been having server problems)


🇦🇺 Australia
1300 135 604
Monday-Friday:9:00 am to 5:30 pm AEST
Using Windows 10 version 17666.rs. MyDrive Connect will not accept my password. Just keeps taking me back to sign in. Same problem with Edge, Firefox and Chrome. Can anyone offer a suggested solution
nigelbrooks wrote:

Had the same problem.

Delete MyDrive Connect and reinstall (takes a couple of minutes).

All now working fine.

Seems that TT screwed somthing up as a 'routine maintenance' screen flash briefly.



It is now working, but has nothing to do with delete and reinstall.
Hi !
Cant login today says error!
Right username and password
My tomtom renault carminat did some update today and now cant login and error appears!
Login wanted to link again to my Renault Carminat account?
You guys been hacked or what?
Error 503 Service Unavailable

Guru Meditation: XID: 1464494797

So, wassup?
Anyone else with this problem?

Cookies

At TomTom, we're all about helping you get around. That's why we use cookies to improve our sites, to offer information based on your interests and to interact with social media. If you're OK with this, you can continue using our sites. Allow Learn more or manage preferences

Allow