Question

iOS unable to purchase


I have downloaded tomtomgo for iOS I’m trying to purchase a years sub but every time it tells me Purchase Unable To Be Completed ? I’ve logged out and back in, re downloaded the app and tried updating payment details etc on my phone and still can’t do it it... why????????


7 replies

Userlevel 7
Badge +5
Hi colw1,

Welcome to the Community!

Can you try enabling the In-app purchases on iPhone as this has resolved the issue for some users? (On the iOS device, open the Settings >General>Restrictions)

Cheers, lampard
@lampard hi thanks for your help.. I’m such an idiot!! I’m sure this was turned on but wasn’t! I’ve checked everything from iTunes update, payment details, memory and settting up a new tom tom account! And all the time in app was off 😞 what an idiot I am... all sorted now thanks ... cheers
i have same problem
can t upgrade on ios , newest ios
inapp purchases are on but cant purchase ...
i tried now 15 times more or less with 3 different payment methods ..

nothing

i read the problem is very old so cant imagine why ..
help needed
I realised on mine that within the settings on iPhone the In App purchases was turned off! That resolved it for me... no idea why off but flicked it on and sorted .....
thx for reply I checked that allready but it was enabled hmm i reinstalled my phone but still
Was it enabled within the Restrictions Tab? If was and still no joy , sorry can’t help further... this is where my issue was ....
it seems the problem is with all in app purchases .. ahh I ll call apple support tomorrow

Reply

    Cookies

    At TomTom, we're all about helping you get around. That's why we use cookies to improve our sites, to offer information based on your interests and to interact with social media. If you're OK with this, you can continue using our sites. Allow Learn more or manage preferences

    Allow Cookie settings