Question

Quick GPS connection


I have an HP iPAQ 6915 that is running well. Now it is impossibile to receive the download of Quick GPS Connection. Can You help me. Before was possible to connect to Tom Tom Home but now is'nt. Wy ? Thanks

This topic has been closed for comments

23 replies

I have the same problem. GPS updates stopped working on my ipaq too on 15/5/12.

Anyone got any ideas ?
BTW the error I get is:

Unable to communicate with the file server.
Details: ProtocolError

This happens when the ipaq is docked with the PC.
I have the same problem.  It appears that the website where the downloads are obtained has changed.  In the 'About' tab, it gives the website as http://www.globallocate.com, but this returns 'page not found'.  It appears that the link to download has changed, but I don't know the new link, and if I did, I don't know how to change this on the ipaq.
I've got the same problem. I have a IPAQ 6515 and I was downloading the Quick GPS without problems. But from about two weeks ago, I can not download the update. The problem is that the server is not located on the same site (http://gllto.glpals.com/) and I do not know the new location of the server or if it continues to said service. It would be terrible to not be able to continue to enjoy these updates. If someone knows or knows something to tell, please.
Hi there,

I had the same problem. After I tried out a lot of changes i made the definite changes in my regfile HP6515. After these changes the svstatus.txt file which is not located any more on the download site http://gllto.glpals.com/7day/latest/ , will not cause an error anymore.

Erase the following:

LocalPath_1 value=Application DataGlobal LocateGpsctsvstatus.txt

RemotePath_1  value= 2day/latest/svstatus.txt

LastDownloadTime_1 value=1601-01-01T00:00:00

RefreshCycle_1 value=7200

MinRefreshCycle_1 value=3600

 

Or better erase these lines in de _setup.xml from your original cab file after extraction and repack it with for example with Mobile Packager software. This modified cab file is always handy for new installations.

 

I hope this helps us all with the old hardware, although I find this same problem on other newer phones to in forums.

 

Note, the 2day has to be changed in 7day for RemotePath_0 (http://gllto.glpals.com/7day/latest/) , this is a very old change and i believe well known. Otherwise the download will never work.

 

Cheers
Vinnie, you are fantastic! Thanks a lot. It has really worked to perfection. This is a fantastic contribution. Thank you.
OK - how do I modify the regfile to do this ? Is there a regedit I have to run or something ?

In the meantime I manually downloaded lto.dat file from http://gllto.glpals.com/7day/latest/ directory, and via ActiveSync I copied it into Application DataGlobal LocateGpsct on the iPaq.

This works but I need a bit more info on how to edit the file vinnie100  is talking about so I can get quickgps running again.
Hi Lochnload,

You can mod your cab file or edit your regfile. The last can with Pocket Controller-Pro you use button registry. Or use a program on your pda like simply regedit directly. The change in your cab file is more complicated.

Succes,

Vinnie100
Didn't work for me.  It now does 3 downloads instead of 4, and reports a ProtocolError at the end.  The bar graph show as if it has updated, but now the SatNav can't find any satellites, even after trying for an hour on my last journey.
Thanks for the reply Vinnie100. I downloaded Pocket Controller-Pro (nice and free for demo) and followed the steps but,

I got the same as rdstewart - 3 downloads and the last one (NtpList) fails with a protocol error.

We are sooooo.... close here.

Loch.
Hi,

You can try a soft reset after the erase off the mentioned lines in the regfile. Are U all using the 6515 or 6915 device? If so it is very strange that you get still this annoying error.

It is supposed to download after the change only the lto.dat file.

Vinnie100
It's a 6515c.

I must be getting old (not trying a reset) but saying that I still get the same error after a reset 😞

Drat ! I will have to come back to this in a couple of days - I'm out of time for now.

Loch.

Kudos to vinnie

 
I'm using a HW6915 and still getting same problem after the soft reset.
Well, I'll explain the steps that I have done, following the instructions in Vinnie100, but with some modifications. First, I have an IPAQ 6515 and I used Resco software to edit the registry key: HKEY_LOCAL_MACHINESoftwareGlobal LocateLto ManagerFiles. I initially followed the directions, which explained Vinnie100 in her first post. I managed to update QUICK GPS. I started the TomTom and quickly recognized the satellites, but the navigator towards a continuous "blinking" on display, what was not something desirable. I did several tests later, and after several attempts I managed the QUICK GPS update, leaving stable the navigator display. Today I tried it with a trip of 150 Km and it was perfectly. 10 Minutes ago, I went to update QUICK GPS and it was perfectly (I do it with 7day, as Vinnie100 says). What modifications I did? Therefore on the basis of the foregoing by Vinnie did the following:
1.-In the value for LocalPath_1 the only thing I did was delete the last character of the string (in this case the letter "t" of .txt).
2- Value for RemotePath_1 did the same that in step 1.
3.-The value of the LastDownloadTime_1 key to leave it exactly as it was.
4.-The value of the MinRefreshCycle_1 key delete it (Note: the value only, but not the key).
5.- The value of the RefreshCycle_1 key delete it (Note: the value only, but not the key).

And everything went perfect. QUICK GPS has updated to 7 days, the browser detected satellites in a few seconds and the trip with TomTom Navigator was correct.

PS: The update is done with data files, although in the end we get a protocol error, because the .txt file is not defined in the corresponding path (steps 1 and 2 above), but has no importance, since the data are updated and thus may be later, running and perfectly detecting satellites.
Hi,

Another approach is to fool the software and make LocalPath_1 the same as LocalPath_2. Also make Remotepath_1 the same as Remotepath_2. You get still the error at the end but the hole setting for software working is original.

Give it a try.

Success all.

Vinnie100

Sea my setting with this mod.

Naamloos.jpg
Hi to all!

I just faced with this problem and want to share my solution.

The solution of vinnie is correct (at least at the time of his writting) but things have changed a little bit more since then.

Not just svstatus.txt is removed from the file repo, but now the other problem is that the file that lists NtpList.txt (network time protocol) servers is also removed from the server. Looks like they have made some changes in their protocol so we must follow.

The following works for me (at least for now):

Simply open some registry editor (I'm using Resco) and navigate to HKEY_LOCAL_MACHINESOFTWAREGlobal LocateLto ManagerFiles and remove the keys which ends with 1 and 2 (LastDownloadTime_1/2, LocalPath_1/2 etc.) and everything should work normally again.
Hi vgfeit,

Your right, just downloading the lto.dat  file and updating the time.txt gives no error and a stable download.

Thats it, i hope its not changing again on the download site.:D

Enjoy this.

Vinnie100
Thanks, everyone. Now working. I was still getting the ProtocolError with vgfeit's suggestion, so tried something different - copied item 3 to item 1, then deleted items 2 and 3.  This works now without any error.

rdstewart,

Nice its working with you to. Still stange that my original option will not work for everyone.

Erase the following:

LocalPath_1 value=Application DataGlobal LocateGpsctsvstatus.txt

RemotePath_1 value= 2day/latest/svstatus.txt

LastDownloadTime_1 value=1601-01-01T00:00:00

RefreshCycle_1 value=7200

MinRefreshCycle_1 value=3600

Priority_1 value= 50

With this setting all still working whith me;

regfile

Cheers...
Hi vinnie100,

My opinion is that it works for you because you may have some sort of cache of known ntp servers (or the quick GPS software don't even tries to find one) and as I can see your last NtpList.txt update time is other than 1601-01-01 (it's 2012-06-09) so it looks like you've successfully synchronized with some NTP server quite recently. This is why (I think) the Protocol Error is raised.

Cheers.
Hi All,

The download site has made all the files needed available again. No mods are needed anymore!

Cheers...
ok vinnie100 . You are the best. Giacomo2012
Vinnie, thank you very much. You're fantastic...

Cookies

At TomTom, we're all about helping you get around. That's why we use cookies to improve our sites, to offer information based on your interests and to interact with social media. If you're OK with this, you can continue using our sites. Allow Learn more or manage preferences

Allow Cookie settings