Solved

GO Mobile on LG G6 and Samsung S8


  • Legendary Explorer
  • 7 replies
With the imminent release of these 2 phones is there any chance that these will work with the app? They both have screens with unusual apsect ratios 18:9 and 18.5:9 respectively. My phone contract is up for renewal and I am considering these 2 phones.
icon

Best answer by Nbphil2 24 July 2017, 15:24

Well to answer my own query it does work on an LG G6. I took the plunge on Friday and upgraded to one from EE and it works perfectly. I suppose I should remember that no news is good news so that if it didn't work then there would people on here complaining about it. But you can see my reason for concern as there are people having trouble with the S8.

View original comment

27 replies

Userlevel 4
Badge +6
HI Phil,

Welcome to the Community!

Our product team is constantly busy testing the app with new phones coming to the market. As these two are popular brands and the new phones are within our current requirements for GO Mobile I don't see any reason for concern here 😃

Perhaps someone has already tested these new phones and can share their experiences here.

Cheers, Mikko
I have just taken delivery of a new Samsung Galaxy S8 and the TomTom Go Mobile app won't load. After installation when I try to open the app I get the TomTom GO Mobile splash screen with a spinning icon saying "loading app". The app just sits on that screen for ever and doesn't complete loading. I have been using the app on my previous handset which was running the same version of Android (7.0)
Userlevel 4
Badge +6
Hi Peter,

Welcome to the Community!

Unfortunately, we're seeing this issue on other phones as well. The following steps have helped many to sort this out:
  • Uninstall the app
  • Log out of the Playstore
  • Delete Android / data / com.tomtom.gplay.navapp and Android / OBB / com.tomtom.gplay.navapp
  • Open the Playstore log in and reinstall

Cheers, Mikko
Hi Mikko
I've tried what you suggested, but it hasn't made any difference
Same here. Can't delete the empty directories. New install won't work.
Userlevel 4
Badge +6
Hi all,

If the above steps don't help you get this sorted, please contact Customer Service. They'll be able to get to the bottom of your issue and assist you accordingly 😃

Cheers, Mikko
Userlevel 1
Hi peterwilki,

The issue is not because of the screen aspect ratios, is because of the UHD screen resolution which is too high. You have to lower the screen resolution to 1920x1080 before using this app, at least till the app will gets an update to work with UHD resolutions.

Found this issue with others apps also.
How do we do that?
Userlevel 1
From the phone menu, see attached pictures.
unfortunately this is not an option. The S8Plus has thre settings. 1480x720, 2220x1080 and 2960x1440.
The middle one was the out-of-the-box default. It didn't work. I tried the two other => No TomTom GO..
Stil have two years payed subscription..
Userlevel 1
For me on Galaxy S7 edge this setting solved de issue.
But one question:
Did you had an SD card installed on your phone when you tried this ?
If yes: try removing it and wipe the App's data (in the phone settings > Apps > GO)
Userlevel 4
Badge +6
Hi all,

Thanks for all your feedback here!

If you're experiencing issues you think might be related to high screen resolution, could you also describe your issue in some detail. Phone model, Android version and the resolution used are also helpful details.

Thanks, Mikko
I posted the issue to customer support
I installed and removed and installed several times. With or without SD card, deleted cache, changed resolution and even told the phone to force TomTom to use the FULL screen (most apps can use only the portion that makes it a normal resolution)
No change. It needs some sort of fix by TomTom.
I use the S8Plus, but if this also happens on the S8 (Same resolution) I expect many users to complain. I am just one of the first since I pre-ordered it. 😞
Userlevel 4
Badge +6
Hi all,

Thanks for all your feedback here! I've forwarded it to the product team.

This seems to be related to the similar issues we're seeing on other phones. I'd recommend you to report it to Customer Service so that we get more information for our investigation into this.

We're very sorry for the inconvenience this is causing you!

Cheers, Mikko
Same issue here, just sticks on the load screen. The same happened when I got my note 4, it took over a year for Tomtom to fix. I have had no other Apps that suffer from having a better display, just Tomtom, twice now.
When I open the App on my old Samsung S5, it also sticks to the load screen! So it's not just for the new phones.
I had the same stuck on loading screen with my s8+ and s7 edge, so i installed older version. Now it is fine
Try this go to https://www.apk4fun.com/history/43374/
Download Old Version: TomTom GO 1.14 APK (Updated: December 8, 2016). You should get a message during the app loading saying that a new version is available in the Play Store. Then download the New 1.6 from the Play Stor, it works on my S8. You will need to be on WiFi.
Hey all,

To give you guys some insight on this from a developer's perspective: we've tested the app on a couple S8/S8+ models and didn't find any issue with different resolutions - the app was able to start and run just fine on the all settings.
That said, we're aware that some users (regardless of device) are getting the dreaded infinite spinner problem. Unfortunately, this issue seems very elusive as we haven't been able to reproduce it ourselves despite many attempts. The next release (1.16.1) should provide us with more information on what might be going wrong, which will hopefully bring us closer to a solution for it.

Your reports that installing an older build first and overwriting it with a newer one to fix it is very remarkable. I can't provide any explanation for this yet, but we'll keep it in mind during our investigation.
Userlevel 2
There are a couple of very small graphical glitches when you switch the the highest resolution on the S8, aside from that, the app runs just fine. The glitches will be fixed in the coming weeks and will be included in our next main app update.
Hi I just downloaded 1.16.1 Still working for me. Strange that you can't simulate in Holland. Are the loading problems only in the UK!
tvkanters wrote:

Hey all,
To give you guys some insight on this from a developer's perspective: we've tested the app on a couple S8/S8+ models and didn't find any issue with different resolutions -



Great to hear what's happening from someone who actually knows whats going on. Have you tried it on an LG G6?
I'm still waiting to hear whether the app is going to work on an LG G6 as I am likely to upgrade to one supplied by EE in the UK...
I have the same issue. But on my S8 it opens the first time and works fine untill I close the app or switch to any other app. Then it wont startup untill I force stop the app.

Reply