Unable to install MySports Connect 3.0.9


During the installation, I receive a long error message saying :

"Failed to create OpenGL context for format QSurfaceFormat[...]. This is most likely caused by not having the necessary graphics drivers installed. Install a driver proviing OpenGL 2.0 or higher [...]"

I never had this kind of error with older version of MySport Connect. I currently use Windows 10 with up to date graphics drivers that are compatible with OpenGL 2.0 an higher. I also tried to run the installation program as an administrator and this doesn't solve the problem, I always have the same error message.

I sent an email to Tomtom support team but they never answered me.

Can someone help me to solve this problem ?

Regards
This topic has been closed for comments

6 replies

Badge +5
Hi Sagimouth,

Welcome to the Forum!

Please see the discussion thread here explaining the workaround for the "Can't create OpenGL context" error: New v3.0.9 of MySports Connect

Hope it helps!

Regards,
lampard
Userlevel 3
Badge
Hi. The forum is being strange with the link. here is a copy of the post


We have found a work around for the "Can't create OpenGL context" error. MySports Connect uses software rendering rather than hardware since this stops problems bugs in older graphics drivers. However it means that it uses older features of the OpenGL specification which newer cards may not support (though they should if they support the OpenGL standard). If you get the "Can't create OpenGL context" error (see https://en.discussions.tomtom.com/mysports-connectappswebsite-389/new-mysports-connect-v309-available-for-download-1010833?postid=1116891 screen shot) then try the following

1. Press Windows+E to open file explorer
2. Copy and paste the following line into the location box at the top

C:\Program Files (x86)\TomTom\MySportsConnect

3. Right click on the TomTom MySports Connect application and select 'Create Shortcut'. It may ask to save the shortcut to to the desktop. If it doesn't then drag the new shortcut from the window onto the desktop
4. Right click on the shortcut and select Properties
5. Click inside the Target box and press the "End" key to move the cursor to the end of the line.
6. Press space and type --hw-gfx (note the 2 dashes at the start).
7. Click Ok
8. Start MySports Connect using the shortcut.

Regards,
Stuart.
I have a similar problem and get this error.
I have tried lots of times, cleared the cache, history, worked around Norton blocking etc., but still get the same result: error.
Anyone who can help me?
Userlevel 3
Badge
j88p wrote:

I have a similar problem and get this error.
I have tried lots of times, cleared the cache, history etc., but still get the same result: error.
Anyone who can help me?

Hi. See this post here
https://en.discussions.tomtom.com/mysports-connectappswebsite-389/nsis-error-update-wont-work-1016019?postid=1147349
you first might want to try adding a parameter to the url (see the bottom of the post where it talks about adding ?forumuser=) since that will definitely stop a cached version being used.

If that doesn't work then check the MD5 and let me know how you get on. I won't be able to get back to you until Monday unfortunately.

Regards,
Stuart.
I read the posts, but am also no computer expert, so I do not really understand any of this. Sorry.
Fortunately, I decided to try again, after my new notebook had done some updates and now it worked fine all by itself!!!
Thank you anyway.
Userlevel 3
Badge
Hi,
See this post
https://en.discussions.tomtom.com/mysports-connectappswebsite-389/tomtommysportsconnectinstallerexe-1018842?postid=1148391
Regards,
Stuart.