Question

MySports Connect opens the URL but needs to refresh the page to continue.


  • Outstanding Explorer
  • 10 replies
When you click on the "TomTom MySports" link on the latest version (3.0.9) of MySports Connect it opens the URL but the page is blank until you press the F5 key or click the refresh button.
I'm using Internet Explorer ver 11.0.9600.18427 on Windows 8.1 64-bit.

Please advise.

9 replies

Userlevel 4
Badge +6
Hi Kevin,

Welcome to the forum and sorry for my late reply!

This is a known issue and we have a fix in the pipelines already 😃

Cheers, Mikko
Will the fix also change the way it opens multiple URLs?
After uploading watch data, it used to open my extra URL in a new tab. Now it opens in a new window.

Thanks!
Userlevel 3
Badge
KevinMc wrote:

Will the fix also change the way it opens multiple URLs?
After uploading watch data, it used to open my extra URL in a new tab. Now it opens in a new window.

Thanks!

Hi. The new version of MySports Connect hasn't changed the way it opens the URLs of uploaded activities, it simply asks the OS to open each URL. If a new browser is opening for each URL then I can only guess that it thinks there isn't a browser open to display the 2nd (and 3rd etc) URL and so starts a new one.

To see if that is the case can you try having a browser open before you connect your watch and see if each URL opens in the browser rather than starting a new browser.

Regards,
Stuart.
If the browser is already open when I connect my watch, both URLs appear in the same window on separate tabs.
If the browser isn't open when I connect my watch, the URLs appear in separate windows.

Sounds like a timing issue.
The 2nd URL must not be giving the 1st URL enough time to open the browser before it tries to determine if a browser is open.

As mentioned above, I use IE as my default browser.
Userlevel 3
Badge
KevinMc wrote:

If the browser is already open when I connect my watch, both URLs appear in the same window on separate tabs.
If the browser isn't open when I connect my watch, the URLs appear in separate windows.

Sounds like a timing issue.
The 2nd URL must not be giving the 1st URL enough time to open the browser before it tries to determine if a browser is open.

As mentioned above, I use IE as my default browser.

Hi. Yes, looks like either MySports Connect is slightly faster or the PC is slightly slower. I'll look at adding a delay between opening the 1st and 2nd urls.

Regards,
Stuart.
MySports Connect must be faster. I'm using the same PC and both URLs opened in the same window in the previous version of MySports Connect.

BTW, as to the original subject, something you may already know ... my 2nd URL (MapMyFItness) doesn't have to be refreshed to get it to display.

No reply necessary. I'll watch for an update. Thanks!
Userlevel 3
Badge
KevinMc wrote:

MySports Connect must be faster. I'm using the same PC and both URLs opened in the same window in the previous version of MySports Connect.

BTW, as to the original subject, something you may already know ... my 2nd URL (MapMyFItness) doesn't have to be refreshed to get it to display.

No reply necessary. I'll watch for an update. Thanks!

Hi. The next version of MySports Connect will have a 3 second delay (configurable if that is still not enough) between opening the 1st and 2nd URLs. Also, a fix for refresh issue on MySports website should now be live.

Regards,
Stuart
Doing it again ... (requires refresh of the page before displaying)
Userlevel 3
Badge
KevinMc wrote:

Doing it again ... (requires refresh of the page before displaying)

Hi. Unfortunately one of the other changes was causing an issue and so the release with the empty page fix was rolled back.
--Stuart.

Reply