Home

Question: Speed Cameras 11 months out of date on brand new START 25


petej42 Author

You can see here how much reputation petej42 has received from other members.

Master Explorer
Replies: 4

29 September 2013, 01:24

I have today purchased a new START 25M Western Europe Sat nav,  I've ran all updates through "my tomtom" and the application and latest maps have updated OK, However the sat nav device says that the the cameras were last updated on 15 nov 2012 - this is a brand new unit. Tried to update through the "Manage content" option on the tomtom website and it says

Speed Cameras Europe - 1 time update

You're not subscribed

Go to shop

 

where it tries to extract another £20 on top of the £120 Ive just paid - is this correct or am i missing something,

  • Zsolt

    You can see here how much reputation Zsolt has received from other members.

    Replies: 24228
    Expert (Android App)

    Expert (Android App)

    Expert (iPhone App)

    Expert (iPhone App)

    Expert (RIDER)

    Expert (RIDER)

    Expert (Car navigation)

    Expert (Car navigation)

    29 September 2013, 17:35

    Give them a call:

    0845 161 0009
    Monday - Friday: 9:00 a.m. to 5:30 p.m. UTC

    or

    020 7387 5444
    I am NOT a TomTom employee, just a user like others. Report map errors at: http://www.tomtom.com/mapshare/tools/# ***One can report temporary road closures too via the MSR Tool now***
  • petej42 Author

    You can see here how much reputation petej42 has received from other members.

    Master Explorer
    Replies: 4

    1 October 2013, 12:38

    Thanks for the advice, rang tom tom support who advised that there is a bug in the tomtom software that shows the cameras as being out of date for which a fix is being worked on.

  • spartan9

    You can see here how much reputation spartan9 has received from other members.

    Neophyte Traveler
    Replies: 2

    2 October 2013, 20:43

    I have exactly the same problem with my START 60 M EUROPE...Which I brought Yesterday !
  • Zsolt

    You can see here how much reputation Zsolt has received from other members.

    Replies: 24228
    Expert (Android App)

    Expert (Android App)

    Expert (iPhone App)

    Expert (iPhone App)

    Expert (RIDER)

    Expert (RIDER)

    Expert (Car navigation)

    Expert (Car navigation)

    2 October 2013, 20:48

    Did it download the latest database via the MyTT app? If yes, it is "just" an issue with displaying the version number.
    I am NOT a TomTom employee, just a user like others. Report map errors at: http://www.tomtom.com/mapshare/tools/# ***One can report temporary road closures too via the MSR Tool now***
  • petej42 Author

    You can see here how much reputation petej42 has received from other members.

    Master Explorer
    Replies: 4

    2 October 2013, 21:26

    I dont recall the camera updates downloading, However,  I did see the application and maps updates go through.,Tom Tom support first told me that it was an application problem, however on further checking with them, their solution was for me to buy a subscription which would then correct the date. (Starnge how a purchased subscription will fix the date yet the "free" one time update will not).They say that the camera updates downloaded with the other updates but to be honest I am not convinced.  All sounds a bit suspicious to me. Currently waiting for a reply to my latest email to tom tom support.

     

    My Start 25 doesnt show a version number for cameras only a last update date which is currently showing 26 November 2012. II asked for details of a recently added camera but they ignored this request.

  • spartan9

    You can see here how much reputation spartan9 has received from other members.

    Neophyte Traveler
    Replies: 2

    3 October 2013, 18:34

    Thanks for the update, did they give you any idea as to time scale of fix ?

  • petej42 Author

    You can see here how much reputation petej42 has received from other members.

    Master Explorer
    Replies: 4

    4 October 2013, 00:47

    They have given me a subscription until 7 oct so that I can retrieve the 1 time update, unfortunately this failed about 6% the way through, They then provided me with instructions to completely remove and reinstall my tomtom, unfortunately this did not work either - they did suggest trying on another computer which, I dont have access to.

     

    Back with them again at the moment, at least they now appear to be trying to sort it out rather than trying to get me to buy a subscription - have you tried contacting them at all?

  • Zsolt

    You can see here how much reputation Zsolt has received from other members.

    Replies: 24228
    Expert (Android App)

    Expert (Android App)

    Expert (iPhone App)

    Expert (iPhone App)

    Expert (RIDER)

    Expert (RIDER)

    Expert (Car navigation)

    Expert (Car navigation)

    4 October 2013, 07:26

    Try some of these in case of installation issues:

    *Always make sure that you are logged in with the correct account to the MyTomTom site AND application. One device, one account*

    - As in IT Crowd: Have you tried to turn the computer off and on again? :)

    - Try to disable your antivirus and firewall (or add the MyTT to the exclusion list)
    - Use Firefox (or Opera, or Google Chrome)
    - Make sure that your computer is not going into stand-by or similar (this shouldn't happen with the latest MyTomTom)
    - Clear the cache before each update attempt. Also could do a soft reset before and after the update
    - Make sure you have the latest Adobe Flash Player and Java installed
    - Make sure you have all the latest updates and hotfixes/patches to your OS
    - In case the device looks like hung during the update or the counter stopped, just leave it. Nost probably it will be fine in a few minutes
    - Check your network connections, make sure that the TT's network adapter is enabled
    - Try to uninstall and re-install the MyTomTom application (best to use Revo Uninstaller to remove)
    - Try to use a USB port on the mainboard, rather than a USB hub (desktop PC)
    - Try to change the port to 5000 (or 5001) in MyTomTom's settings
    - Try to run the MyTomTom app in Windows XP compatibility mode
    - Try to run the MyTomTom app as administrator

    - In case it is not working with your browser, try other browsers (Opera, Google Chrome, Firefox, Internet Explorer)
    - Don't use any Flash Blocker (check Flash Blocker plug-in in browser)
    - Google Chrome, Internet Explorer 10 and Internet Explorer 11 have a built-in flash which can cause trouble

    - Any further issue: Try it on another PC, try it with different USB lead...the shorter the better (below steps are Windows specific)
    - Whilst the device connected, remove the drivers from the Device Manager (Windows/Control Panel), DELETE the drivers
    - Remove the MyTomTom application and run CCLEANER (will remove your history, cookies, etc by default)

    - At the moment USB 3 looks like doesn't like TT devices
    - Don't use the magnetic mount whilst updating, connect the micro USB directly into the device
    - Disable any network monitoring software
    - Update one item at a time, don't select all. Best order: NavCore/software - Map - QuickGPSfix - Speed Cams - Map Share Corrections (this is the smallest but longest)

    For Windows 8 or 8.1 you can try the below (to make it work with IE10 and IE11):

    - always run the MyTT app as administrator (pin it to the task bar, right click, right click again, properties, compatibility setting, tick run as administrator)
    - make sure that the Shockwave Flash is enabled in IE add-ons
    - add tomtom.com to the compatibility view
    - make sure the IE11 is set to open the pages ALWAYS in desktop view (not IE view or don't let IE to decide)
    I am NOT a TomTom employee, just a user like others. Report map errors at: http://www.tomtom.com/mapshare/tools/# ***One can report temporary road closures too via the MSR Tool now***
  • petej42 Author

    You can see here how much reputation petej42 has received from other members.

    Master Explorer
    Replies: 4

    10 October 2013, 23:51

    Thanks for the tips, pretty much the same advice as provided by tomtom support desk. tried running as admin but no joy either, Took the sat nav back to the store where I purchased it and their tech team tried to run the updates and encountered the same problems, so not a laptop prtoblem,

     

    Have now returned the item to the store and received a refund. Back to my 6 year old tomtom one. Pity really, the smart looked like a nice bit of kit, 5 Inch screen, easy to use,Lifetime maps Newer model, etc  but one of the reasons I wanted to update to a newer model was for the camera updates, but after the grief of trying to get the 1st time update to the cameras, it really doesnt seem worth it.

  • OldChelt

    You can see here how much reputation OldChelt has received from other members.

    Apprentice Traveler
    Replies: 1

    15 February 2014, 11:57

    Similar problem today with a new TomTom 135Via that includes "free" lifetime maps. Thought that might have included at least one years speed camera alerts One time speed camera downloaded and still saying last updated 15th July 2013 - its now 15th Feb 2014! Paid for a years speed camera updates and still showing out of date. How long doesTT need to fix this bug?

  • wrog

    You can see here how much reputation wrog has received from other members.

    Apprentice Traveler
    Replies: 2

    24 February 2014, 01:24

    Hi

    I have the same problem with Via 130 new in Dec 2013 loaded and it says cameras last updated June 18th 3013, Despite contacting Tomtom on a number of occasions they do not want to resolve this problem, they just say that there is a bug in the software and to try this or that, also asked me to pay for an update.

    I strongly believe that it is in their interests not to find this so called bug and to rip off the customers in Europe, they would not do this in the USA. I am currently taking legal advice on this matter.

  • Viking66

    You can see here how much reputation Viking66 has received from other members.

    Apprentice Traveler
    Replies: 1

    15 June 2014, 01:44

    Hi Newbie here with the same issue, bought a new start25 Western Europe today and after three hours of trying to link it I finally got it to update it's WE map...then moved on to the traffic cameras....I didnt realise you could contact tomtom to get the device updated as my camera db was dated 15th July 2014....almost a year out of date...not great for a £100 bit of kit...so I paid £20 for the new db, downloaded it to the device and what do you know?....still says 15th July 2013....so tell me, how do I know I REALLY did get  my db updated......Ok, yes the content screen on mydrive says i have installed a premium db and it runs out on the 15/6/2015 but why doesn't the actual device I own reflect this change?

     

    Beginning to think I should have just paid for the later map for my one xl from 2006!!! instead of buying a brand new tomtom 25 WE.....come on TomTom, fix the bug...cheers.

     

    I ask myself, what would Ragnar Lothbrok do..

  • wilko53

    You can see here how much reputation wilko53 has received from other members.

    Apprentice Traveler
    Replies: 2

    22 June 2014, 13:09

    how do you overcome speed camera out of date or speed cameras not warning as it says cameras active on tomtom

  • bonzoid

    You can see here how much reputation bonzoid has received from other members.

    Apprentice Traveler
    Replies: 1

    10 July 2014, 17:30

    I'm yet another purchaser of start 25 (bought yesterday) and have the same problem with speed cameras being out of date.  Has anyone sorted this out yet.  Surely Tomtom must have responded properly to the many complaints about this.

     

  • Zsolt

    You can see here how much reputation Zsolt has received from other members.

    Replies: 24228
    Expert (Android App)

    Expert (Android App)

    Expert (iPhone App)

    Expert (iPhone App)

    Expert (RIDER)

    Expert (RIDER)

    Expert (Car navigation)

    Expert (Car navigation)

    10 July 2014, 22:48

    There was an error at TT's end until today (for almost a month). It is fixed by now (just downloaded the latest cameras today).
    I am NOT a TomTom employee, just a user like others. Report map errors at: http://www.tomtom.com/mapshare/tools/# ***One can report temporary road closures too via the MSR Tool now***
  • jackdog

    You can see here how much reputation jackdog has received from other members.

    Neophyte Traveler
    Replies: 3

    18 July 2014, 14:07

    Hi all

     

    I have the same problem with a recently purchased unit , i made the mistake of buying an update only to find later that clicking on speed cameras in mycontent showed i now had updates untill 2016 ! .

    The Start 25 is still showing the camera DB as out of date , i have tried a reset to defaults and re-install etc but its made no difference , do i assume that the speed cams are up to date and ignore the out of date warning ?, i have filled an on-line contact form re this but no reply .

  • jackdog

    You can see here how much reputation jackdog has received from other members.

    Neophyte Traveler
    Replies: 3

    18 July 2014, 16:57

    Just heared from Tomtom and they acknowledge there is an on-going problem but assure me the Start 25 is up to date although they said the subscription was till 2015 , hope that was a typo !.

  • jackdog

    You can see here how much reputation jackdog has received from other members.

    Neophyte Traveler
    Replies: 3

    18 July 2014, 21:02

    Think i mis-read mydrive , it doesn't say 2016 expirey (not now anyway :manembarrassed:) and i thought the free update was a year , TT put me right so i just have to wait for the fix on the device now

  • MikkoKMikkoK

    You can see here how much reputation MikkoK has received from other members.

    Staff
    Replies: 6640
    Expert (Multi-sport)

    Expert (Multi-sport)

    Expert (Runner)

    Expert (Runner)

    Expert (Golfer)

    Expert (Golfer)

    Expert (Android App)

    Expert (Android App)

    Expert (iPhone App)

    Expert (iPhone App)

    Expert (RIDER)

    Expert (RIDER)

    Expert (Car navigation)

    Expert (Car navigation)

    23 July 2014, 15:06

    Hi Jack,

    Thanks for reporting your issue!

    There's indeed a technical issue due to which the device might show incorrect date of the speed cameras. However, most often this is caused by one or more of the camera files not being installed/updated. The device is showing the date for the oldest file. You can check the status of the camera files in the My Content page in MyDrive and re-install the cameras, if needed.

    Cheers, Mikko
    Help others identify useful content: - Did someone answer your question? Click Mark as Solution - Did someone post something helpful? Click the kudos button - Need help with your TomTom device? Add details about the TomTom device to your post: Device name, Application- and Map version.

Reply to this post

Uploading in progress:
0%
Browse
Add
If the URL is correct, a preview will appear here. It can take a few minutes for larger images to show.
  • :D
  • :?
  • :cool:
  • :S
  • :(
  • :@
  • :$
  • :8
  • :)
  • :P
  • ;)
View mobile version
Powered by Insided