Question

Unable to sync TomTom Spark GPS watch with iPhone


I updated the software on my watch last night and haven't been able to pair my watch with my phone since. The watch will search for my iPhone and will briefly provide a pin code to enter before the code then disappears before the phone even finds the watch. Has anyone else experienced this pairing issue since updating their phone and been able to fix the problem? Mine now has software version 1.7.53.

Thanks

95 replies

Mine is doing exactly the same. I have reset the watch, reset phone, reinstalled App.
Userlevel 2
hi,

You have to wait for new firmware, TOmTOm Staff is looking for the stolution. There is new beta firmware 1.7.58 in tests.

Cheers, Maciek
Sparx86 wrote:

I updated the software on my watch last night and haven't been able to pair my watch with my phone since. The watch will search for my iPhone and will briefly provide a pin code to enter before the code then disappears before the phone even finds the watch. Has anyone else experienced this pairing issue since updating their phone and been able to fix the problem? Mine now has software version 1.7.53.

Thanks


You can ask Tom Tom to roll back the software on the watch to 1.3.255.
I add the exact same issue. What worked for me (without rolling back to a previous firmware version) was to have the Iphone "forget" the watch.
Deleting the watch from the TomTom app was not sufficient.
I went into the BlueTooth settings of the Iphone, deleted my TomTom watch and started again the sync process from the TomTom app.
And it worked this time, i could see the "pin" being displayed on the watch, then i entered it on the Iphone and that was it.
Hope this helps.

Regards, Pascal
Can’t even connect the earphones. Hope that’s in the fix as well
same exact issues here from me, hope to rollback to 1.3.255 as soon as i can
Badge +5
thehet wrote:

same exact issues here from me, hope to rollback to 1.3.255 as soon as i can



Welcome to the Community!

Please perform a factory reset on your watch and the version 1.3.255 will be offered to you in Sports Connect to install.

Cheers, lampard
Userlevel 4
Badge +2
thehet wrote:

same exact issues here from me, hope to rollback to 1.3.255 as soon as i can

When you now do a factory reset you will get the old build installed.
when I do the factory reset the clock does not stay with firmware 1.3.255. What do I do?
Userlevel 4
Badge +2
pmco wrote:

when I do the factory reset the clock does not stay with firmware 1.3.255. What do I do?

Your watch will return to 1.3.255 when you do another factory reset now.
Jürgen wrote:

thehet wrote:

same exact issues here from me, hope to rollback to 1.3.255 as soon as i can

When you now do a factory reset you will get the old build installed.



i can confirm that rolling back to 1.3.255 version solved the connectivity issues with ios 11 working like a charm on the first try, hope to get the next version firmware when it's fixed to get the new functionalities as well.
thank you for fast and excellent support.
I am having the same issues Re: Pairing after software update. Factory reset did not work for me, I was not asked which software version I wanted to install.
I have same problems. Won’t sync with app since update. More annoyingly no reply to my email.
I thought it was my fault!! Bought this watch just a few weeks ago and triedseveral times to make a bluetooth connection with my phone and the headset. No results; tried everything. Think I will sent it back...)-:
I also have exact same issue after update software to 1.7.53. Currently I was not able to upload to my device record to web from computer.
When will tomtom release that countermeasure software? I already spent about 1 month on this status. It's so inconvenience.
Hi Jürgen, can you please let me roll back to 1.3.255? I'm also experiencing sync issues.
Userlevel 4
Badge +2
martijnk wrote:

Hi Jürgen, can you please let me roll back to 1.3.255? I'm also experiencing sync issues.

Your account is now linked to 1.3.255.
Hi Jürgen,

Can You configure my watch to version 1.7.60 ?
Thanks in Advance
Thanks. Sync is working again!
Jürgen wrote:

martijnk wrote:

Hi Jürgen, can you please let me roll back to 1.3.255? I'm also experiencing sync issues.

Your account is now linked to 1.3.255.



Please Jürgen, can you link my account to 1.3.255 as well?
I need to downgrade my Spark 2 due to connectivity issues.
Thanks
Userlevel 4
Badge +2
[quote=eaude]
Jürgen wrote:

Please Jürgen, can you link my account to 1.3.255 as well?
I need to downgrade my Spark 2 due to connectivity issues.
Thanks

Done.
please Jürgen, I need to downgrade my Spark 2 due to connectivity issues.
Thanks
please Jürgen, I need to downgrade my Spark 2 due to connectivity issues.
Thanks
Userlevel 4
Badge +2
Manu Zatopek wrote:

please Jürgen, I need to downgrade my Spark 2 due to connectivity issues.
Thanks

Done.
thank you very much!!

Reply