Unable to pair/sync after update to firmware v1.7.53 | RUNNER and SPARK watch series


  • Master Explorer
  • 5 replies
i have been unable to connect my phone(BT) to my watch after this update.

Whe i try to pair device, the watch show the pins to enter but the phone apps is always in the "conneciton in progress" page.

459 replies

It's working perfect for me. Samsung Galaxy S7 edge, Manual synch. And the latest update is amazing
A history check on the similar topic found this happen before to older version firmware. There is no pin pad prompt from phone. is there any TomTom representative here or does anyone here knows how do we request support from TomTom so that i can provide them with details such as phone/fimware version or any logfile if they need.
I have the same problem. I can't pair with my Xperia or my wife's Samsung it's frustrating. You can report the problem using the app and send the logs. Just go to settings - feedback - report a problem. I did it 3 days ago and have heard nothing.
thanks Kev1980
Heard back today, apparently a new update is available with a fix today. Can't wait to try later.
Same problem here. Just bought my Spark Cardio today, battery charged, firware upgraded to 1.7.53, TomTom Sports app installed on my iPhone. When I try to pair the watch to the phone, the watch briefly displays the PIN, then slides back to the left to the menu (PIN disappears) meanwhile the phone stays on the connection screen. Disappointed with TomTom on the very first day...
after upgrade doesn`t work properly, can`t connect with phone.
I was offered upgrade 1.7.53, and about shows 1.7.53, now the synch doesn't work to my phone Galaxy J5. It connect by wire to PC, shows all my workouts but frustrating. Will I lose anything (inc off my PC) if I do a factory reset? Bluetooth just keeps trying to find phone unsuccessfully
gabbat wrote:

Same problem here. Just bought my Spark Cardio today, battery charged, firware upgraded to 1.7.53, TomTom Sports app installed on my iPhone. When I try to pair the watch to the phone, the watch briefly displays the PIN, then slides back to the left to the menu (PIN disappears) meanwhile the phone stays on the connection screen. Disappointed with TomTom on the very first day...



Same problem. Working fine on old firmware. Forced upgrade from TomTom onto the phone and lo and behold, will no longer BT sync. Syncs, gets to 4%, drops connection .... then goes through cycle again. Repeats it a few times, then tells me to perhaps plug my watch in using USB to help it sync. Which makes no difference whatsoever. The ONLY thing that has changed is the firmware upgrade. I have changed nothing else.

Come on TomTom, test it properly before pushing it out and using us a guinea pigs to test it!! I have my first marathon tomorrow so I am not best pleased (to put it extremely politely) that the watch is u/s right at this point in time due to bug-ridden firmware from TomTom.
I tried the factory reset. It does delete all your data on the watch, but the 1.7.53 firmware remains.
Kev1980 wrote:

Heard back today, apparently a new update is available with a fix today. Can't wait to try later.



Any news about the update yesterday? Was it released?
It turned out that they were on about 1.7.53 which is the same software I was running. So still not very happy. 😞 I am running my first half marathon next week and I can't believe I'll have to wait til I get home to review my run on my PC!
I've emailed them back will update when I get a response!
Same issue here; after update to 1.7.53 my Spark 3 doesn't connect to my iphone 7 (ios11.02) anymore. I tried everything ; deleting the sports app, restarting, re-installing (twice); factory reset with recovery setting on the watch (twice). Have to sync through the PC now so I'm very disappointed. Hope TT will release an update soon cause this is not why I bought this watch.
My runner 3 has upgraded to 1.7.53.

bluetooth syncing to android phone is much worse than it used to be. I have got it to sync. it can take half an hour of waiting, restarting bluetooth. killing and restarting app. sometimes it gets to 40% or so sync and then stops. my activities dont make it across.

It's quicker to boot and log in to an old and slow computer and use a USB cable.
I also have the syncing problem with a Samsung S7. Tried to unpair/pair/factory reset; and watch gives the code to enter but the app just hangs on the 'connecting' screen.
Since I update the firmware to 1.7.53 last week, the watch automatically keep on moving the cursor down and become not functioning. Cannot recover even after factory reset. When the battery is gone eventually, I tried with the factory reset with USB and the watch seems to be normal again. Yet when synchronization is done with the mobile apps(which takes time longer than normal) the 'cursor down' phenomenon come back again!!! Please solve the problem ASAP!!!
I found re-pairing took many attempts on 1.7.53. When I managed, I found a trick that improves syncing my runner 3 to my android (pixel).

1. In the app tap on the top item (that says "waiting for watch" etc). turn off "android notification".
2. on the watch go down to phone, right to manage, right to syncing and set to manual.

To sync, open the app on your phone, and go down from the clock screen on your watch. it's not 100%, but the sync is way more reliable than the default settings.
Same prob here too. After installing the 1.7.53 update, bluetooth sync with the Sports app on an iPhone 6S running iOS 11.0.2 is now broken.

Exact same issue as described here:

https://en.discussions.tomtom.com/spark-and-spark-3-runner-2-and-runner-3-473/runner-3-bunch-of-problems-since-last-update-1-7-53-1028501/index1.html#post1191729

The other problem is that the watch seems to freeze occasionally, showing an old time. And yesterday morning when I put my hand over the watch to activate the light, it seemed to stay on for longer than usual. I think the time freezing and light staying on longer than usual seem to happen together.
Userlevel 4
Badge +2
djluko wrote:

Same prob here too. After installing the 1.7.53 update, bluetooth sync with the Sports app on an iPhone 6S running iOS 11.0.2 is now broken.

Exact same issue as described here:

https://en.discussions.tomtom.com/spark-and-spark-3-runner-2-and-runner-3-473/runner-3-bunch-of-problems-since-last-update-1-7-53-1028501/index1.html#post1191729

The other problem is that the watch seems to freeze occasionally, showing an old time. And yesterday morning when I put my hand over the watch to activate the light, it seemed to stay on for longer than usual. I think the time freezing and light staying on longer than usual seem to happen together.

The freeze and back light issue sound like a bad installation. Can you please try a factory reset in the Settings of TomTom Sports Connect? If it's not fixed let me know if you want me to roll you back to the old build until we have a fix.

P.S.: After the reset you need to make your iPhone forget the watch in the iOS Bluetooth settings.
Jürgen wrote:

If it's not fixed let me know if you want me to roll you back to the old build until we have a fix.

P.S.: After the reset you need to make your iPhone forget the watch in the iOS Bluetooth settings.



Could you please share with us how to roll back to a previous build?
Userlevel 4
Badge +2
Tiago Miranda wrote:

Could you please share with us how to roll back to a previous build?

I have linked your account to the previous build until we have a fix. When you now do a factory reset the old build will be installed.
I have the same problem, since the installation of version 1.7.53 does not connect to the application. Can you connect to version 1.3.255, please?
Jürgen wrote:

I have linked your account to the previous build until we have a fix. When you now do a factory reset the old build will be installed.



ohh ... that's not what I wanted. I thought there was a DIY way to revert to an earlier version whenever I wanted to. In fact I am at 1.6.26 right now, anxious to try the new version. Can you undo that? Thank you.
Userlevel 4
Badge +2
Tiago Miranda wrote:

ohh ... that's not what I wanted. I thought there was a DIY way to revert to an earlier version whenever I wanted to. In fact I am at 1.6.26 right now, anxious to try the new version. Can you undo that? Thank you.

You're back on the regular server.

Reply