Home

Rider 40/400 stopped working after recent software upgrade

Tags:
rider, update, stopped working, Rider 40/400,

thewombat Author

You can see here how much reputation thewombat has received from other members.

Outstanding Explorer
Replies: 19

6 March 2017, 04:17

My TT40/400 is 11 months old. Until recently it has worked very well. The problem started after the recent major software update was downloaded. When I turn it on after a few moments it goes blank then the start up screen (blue/gray map of the world) appears. The menu options freeze and don't allow me to navigate and I can't do anything but turn it off and back on and I may get a successful restart that displays the map and the menu options work again, but a short period it crashes again. I deleted and reinstalled the maps, as it appeared the maps were failing to load into the unit's memory, just in case corrupted map files were causing the problem. When this did not resolve the problem I reset the unit to factory settings but that has not worked either. Just meant I've lost all my favorite settings, routes and places. Strangely today the unit still recorded trip statistics, even though the screen was blank (no map). However, the headset and i-Phone connected OK and were and working. This makes me think the issue is a software problem, not a hardware problem. I need help. Can anyone advise me how to get my Tom Tom 40/400 working again?
Show first post Hide first post

127 comments

  • thewombat Author

    You can see here how much reputation thewombat has received from other members.

    Outstanding Explorer
    Replies: 19

    20 March 2017, 06:52

    The Oceania map seems to work OK, and has enabled me to set several routes and save them into My Routes. Today however it malfunctioned again. I set the Rider 400 for a 110 Km ride across the Blue Mountains without any problem and when I arrived at my destination and set a route for Home it took an unusually long time to find the fastest route (It should have been much faster) and when it got to the point where it asks you you press the Let's go button it froze. I had to shut it down holding the on/off button then turn it on again holding the on/off button until the drum roll, then it worked fine after that. So there might to be some residual problem with the Rider 400. But at least it works and can be used.
  • MikkoKMikkoK

    You can see here how much reputation MikkoK has received from other members.

    Community Manager
    Replies: 15297
    Expert (Multi-sport)

    Expert (Multi-sport)

    Expert (Android App)

    Expert (Android App)

    Expert (iPhone App)

    Expert (iPhone App)

    Expert (RIDER)

    Expert (RIDER)

    Expert (Car navigation)

    Expert (Car navigation)

    Expert (Golfer)

    Expert (Golfer)

    Expert (Runner)

    Expert (Runner)

    20 March 2017, 13:59

    Hi gas667,

    Welcome to the Community!

    I've assigned the Oceania map on your account and you can now install it with MyDrive Connect.

    Cheers, Mikko
    Help others identify useful content: - Did someone answer your question? Click Mark as Solution - Did someone post something helpful? Click the kudos button - Need help with your TomTom device? Add details about the TomTom device to your post: Device name, Application- and Map version. Check our support videos at tomtom.com/videosupport
  • gas667

    You can see here how much reputation gas667 has received from other members.

    Apprentice Traveler
    Replies: 2

    20 March 2017, 23:23

    Thanks Mikko

    I will check it out tonight and post back.

    gas667
  • d.mcmillan7

    You can see here how much reputation d.mcmillan7 has received from other members.

    Apprentice Traveler
    Replies: 2

    23 March 2017, 06:22

    Now have Oceana map and seems to work fine. I can't believe a modern technology company like tomtom couldn't have emailed registered owners of their failure and fix instead of leaving them to waste time searching for the fix
  • Mikoz

    You can see here how much reputation Mikoz has received from other members.

    Neophyte Traveler
    Replies: 3

    23 March 2017, 08:25

    Ok, I've seem to have exactly the same problem with my new Australia map v985.8204
    Background: I purchased the Rider 400 while in Europe after the Garmin 660 I was using died. So only had the Europe maps and worked perfectly. Purchased the Australia map back here and now have the symptoms everyone else is describing. But also can not switch back to Europe map (just says 'loading' forever...).
    MikkoK, Can I get access to the Oceania map as the workaround?
  • MikkoKMikkoK

    You can see here how much reputation MikkoK has received from other members.

    Community Manager
    Replies: 15297
    Expert (Multi-sport)

    Expert (Multi-sport)

    Expert (Android App)

    Expert (Android App)

    Expert (iPhone App)

    Expert (iPhone App)

    Expert (RIDER)

    Expert (RIDER)

    Expert (Car navigation)

    Expert (Car navigation)

    Expert (Golfer)

    Expert (Golfer)

    Expert (Runner)

    Expert (Runner)

    23 March 2017, 09:11

    Hi Mikoz,

    Welcome to the Community!

    I have assigned the Oceania map to your account and you can now install it with MyDrive Connect.

    Cheers, Mikko
    Help others identify useful content: - Did someone answer your question? Click Mark as Solution - Did someone post something helpful? Click the kudos button - Need help with your TomTom device? Add details about the TomTom device to your post: Device name, Application- and Map version. Check our support videos at tomtom.com/videosupport
  • Mikoz

    You can see here how much reputation Mikoz has received from other members.

    Neophyte Traveler
    Replies: 3

    23 March 2017, 09:38

    Mikko, That was an amazing fast response - Thank you.
    I'll download tonight and test tomorrow.
  • Mikoz

    You can see here how much reputation Mikoz has received from other members.

    Neophyte Traveler
    Replies: 3

    24 March 2017, 07:11

    As others have found, after loading the Oceania map the device works correctly. I'm also able to switch to the Europe maps again and run preview routes - could not do this with the Australia map loaded.
    Mikko, thanks again for providing the work around map so quickly
  • peterj102938

    You can see here how much reputation peterj102938 has received from other members.

    Neophyte Traveler
    Replies: 3

    24 March 2017, 08:57

    I had a similar problem with my Rider 400 which occurred in mid-December last year. Luckily I was able to get a replacement because, in Australia, it was considered a "Major Failure" under the terms of the Australian Consumer Law. Good luck!!!
  • MikkoKMikkoK

    You can see here how much reputation MikkoK has received from other members.

    Community Manager
    Replies: 15297
    Expert (Multi-sport)

    Expert (Multi-sport)

    Expert (Android App)

    Expert (Android App)

    Expert (iPhone App)

    Expert (iPhone App)

    Expert (RIDER)

    Expert (RIDER)

    Expert (Car navigation)

    Expert (Car navigation)

    Expert (Golfer)

    Expert (Golfer)

    Expert (Runner)

    Expert (Runner)

    24 March 2017, 09:19

    Hi Peter,

    Welcome to the Community!

    I'm happy to hear you got your issue sorted! :D It sounds like you had a hardware issue. The issue discussed here has to do with the latest software (v16.601) and the map of Australia. Luckily we have a workaround for it as replacing a device for a software fault doesn't help.

    Cheers, Mikko
    Help others identify useful content: - Did someone answer your question? Click Mark as Solution - Did someone post something helpful? Click the kudos button - Need help with your TomTom device? Add details about the TomTom device to your post: Device name, Application- and Map version. Check our support videos at tomtom.com/videosupport
  • peterj102938

    You can see here how much reputation peterj102938 has received from other members.

    Neophyte Traveler
    Replies: 3

    24 March 2017, 09:48

    Having read through the posts in this thread, I now am concerned that my new Rider 400 is/will be subject to the problems listed above. I tried to update the maps on Wednesday (22nd) and had a lot of trouble. The first attempt to update the maps failed and left the Rider without an Australian map. The second attempt loaded the Australian map but corrupted the NZ map!!! I decided to cut my losses and fix the NZ map later.
    I thought everything was ok until last night when using the Rider in the car. About half way through the journey, it stopped giving directions as it had frozen. After switching it on and off several times it seemed to partially fix itself but was acting a bit weird. I didn't have time to get to the bottom of the problem as I was late for a meeting.
    Today I have switched the unit on and off several times to see if it was having the same problem loading the maps as my previous unit but, so far, it seems to be loading the Aussie map ok. I haven't tried taking it out to see if it can follow a route without freezing again.

    I have checked and the Aussie map in my unit is 985.8204 and the Application Version is v16.601 .

    It looks to me that the weird behaviour I witnessed last night is similar to what the other Posters have been experiencing. Therefore, could you please assign the Oceania map to my account also, so I can get my Rider running again reliably.
    Cheers
  • MikkoKMikkoK

    You can see here how much reputation MikkoK has received from other members.

    Community Manager
    Replies: 15297
    Expert (Multi-sport)

    Expert (Multi-sport)

    Expert (Android App)

    Expert (Android App)

    Expert (iPhone App)

    Expert (iPhone App)

    Expert (RIDER)

    Expert (RIDER)

    Expert (Car navigation)

    Expert (Car navigation)

    Expert (Golfer)

    Expert (Golfer)

    Expert (Runner)

    Expert (Runner)

    24 March 2017, 10:25

    Hi Peter,

    That indeed sounds like the issue described here. I've assigned the Oceania map on your account and you can now install it with MyDrive Connect.

    There seem to have been some interference with our internet connection causing the Australia map download to fail on the first time. Should you run into more trouble updating your device, please see, this FAQ for MyDrive Connect troubleshooting tips.

    Cheers, Mikko
    Help others identify useful content: - Did someone answer your question? Click Mark as Solution - Did someone post something helpful? Click the kudos button - Need help with your TomTom device? Add details about the TomTom device to your post: Device name, Application- and Map version. Check our support videos at tomtom.com/videosupport
  • peterj102938

    You can see here how much reputation peterj102938 has received from other members.

    Neophyte Traveler
    Replies: 3

    24 March 2017, 22:49

    Thanks Mikko. I will install the Oceania map and see how it goes.
    I also have a question regarding Europe maps I purchased for my TomTom Go 600. Could you tell me the correct forum to start that discussion please?
  • ToeCutta

    You can see here how much reputation ToeCutta has received from other members.

    Apprentice Traveler
    Replies: 2

    26 March 2017, 11:42

    Hi folks, looks like I am another rider caught with the Defective 985 map. Can you post the Oceania map to my account so that get back on track.
    Cheers
  • MikkoKMikkoK

    You can see here how much reputation MikkoK has received from other members.

    Community Manager
    Replies: 15297
    Expert (Multi-sport)

    Expert (Multi-sport)

    Expert (Android App)

    Expert (Android App)

    Expert (iPhone App)

    Expert (iPhone App)

    Expert (RIDER)

    Expert (RIDER)

    Expert (Car navigation)

    Expert (Car navigation)

    Expert (Golfer)

    Expert (Golfer)

    Expert (Runner)

    Expert (Runner)

    27 March 2017, 09:52

    Hi ToeCutta,

    Welcome to the Community!

    I've assigned the Oceania map to your account and you can install it with MyDrive Connect.

    @ Peter: Please, post your GO 600 related question here.

    Cheers, Mikko
    Help others identify useful content: - Did someone answer your question? Click Mark as Solution - Did someone post something helpful? Click the kudos button - Need help with your TomTom device? Add details about the TomTom device to your post: Device name, Application- and Map version. Check our support videos at tomtom.com/videosupport
  • ToeCutta

    You can see here how much reputation ToeCutta has received from other members.

    Apprentice Traveler
    Replies: 2

    27 March 2017, 11:56

    Hi MikkoK,

    Thanks for your assistance. :)
  • BryanM63

    You can see here how much reputation BryanM63 has received from other members.

    Neophyte Traveler
    Replies: 3

    28 March 2017, 05:12

    thewombat wrote:

    Thanks for the advice dhn. I called Tom Tom support later today when I realized my efforts were not going to be successful. T T said they are aware of this problem. The latest software update has a bug which prevents the Rider 40/400 from accessing the maps. The upgrade works fine with all the other TT devices except the Rider 40/400. Their software team are working to resolve this and they will be issuing a new upgrade soon which should fix the problem. Meantime I should use paper maps to navigate! My assessment was not that far wrong. It is a software problem and it started with the upgrade released in early February.



    Thanks for the info thewombat.
    Tomtom's solution is just not good enough, use paper maps FFS, we don't pay high prices for a motorcycle GPS only to find out they issue firmware updates that are untested and then expect us to use a paper map what do they think we are savages!
    Some info for my problem. I just returned home from a trip to Sydney. Before I left I decided I'd "do the right thing" and make sure my Tomtom is up to date. So I updated it on the 16th March and left home on Monday the 20th. Immediately I noticed it dropping in and out but usually recovering quickly. I wondered what was going on. Over the next couple of days I started experiencing the same symptoms you describe. Now this leads me into Sydney, where I haven't been in over 20 years! To say the least I was bloody lost.

    Now I get home and carry out the restore process, only to find out that it doesn't rollback the firmware. What is the point of that? if you've got dodgy firmware what is the point in reinstalling it?
    Come on TomTom it is time you got your S*#T together and create a facility to effectively rollback the firmware so users can use their devices as intended.
  • MikkoKMikkoK

    You can see here how much reputation MikkoK has received from other members.

    Community Manager
    Replies: 15297
    Expert (Multi-sport)

    Expert (Multi-sport)

    Expert (Android App)

    Expert (Android App)

    Expert (iPhone App)

    Expert (iPhone App)

    Expert (RIDER)

    Expert (RIDER)

    Expert (Car navigation)

    Expert (Car navigation)

    Expert (Golfer)

    Expert (Golfer)

    Expert (Runner)

    Expert (Runner)

    28 March 2017, 10:42

    Hi Bryan,

    I'm sorry to hear that you're also suffering from this issue!

    I've assigned the Oceania map to your account and you can now install it with MyDrive Connect. You can keep using your device with that until we find a solution to the issue.

    Cheers, Mikko
    Help others identify useful content: - Did someone answer your question? Click Mark as Solution - Did someone post something helpful? Click the kudos button - Need help with your TomTom device? Add details about the TomTom device to your post: Device name, Application- and Map version. Check our support videos at tomtom.com/videosupport
  • BryanM63

    You can see here how much reputation BryanM63 has received from other members.

    Neophyte Traveler
    Replies: 3

    31 March 2017, 03:25

    Thanks Mikko,
    I didn't come on here to bitch and moan, I came on here looking for answers. When I read Wombats original post and Tomtom's response to him I was fuming! Especially after being left stranded with a temperamental unit in a city I was unfamiliar with. I can only guess the support person he spoke to is not a motorcyclist.
    Reading his post and then the rest of the thread at least gave me the reassurance that I hadn't bricked my device. I thought I'd need to ring TomTom support for the Oceania map. So once again thank you for the Oceania Map. I am currently downloading it and will try it out as soon as it is ready. :)
  • Duckaroo

    You can see here how much reputation Duckaroo has received from other members.

    Neophyte Traveler
    Replies: 3

    3 April 2017, 10:41

    Hi MikkoK,

    I am having the same dramas with a one week old Rider 400. I have only the Australian map (V9.85) loaded.
    Could you please assign the Oceania map to my account as well?

    Thanks :)
  • thefathippy

    You can see here how much reputation thefathippy has received from other members.

    Neophyte Traveler
    Replies: 3

    3 April 2017, 13:46

    Hi MikkoK

    I saw thewombat's post on my club's Facebook page, unfortunately, just after updating my gps, and haven't used my Rider 400 since. I also have Australia, New Zealand, and Southeast Asia maps v985.8204. Based on comments here, I assume I'll have the same problem with my gps as the others have. I'm going on some trips soon, and don't want problems on the road. Can you please assign the Oceania maps to my account as well?

    Thanks

    Tony F
  • thefathippy

    You can see here how much reputation thefathippy has received from other members.

    Neophyte Traveler
    Replies: 3

    3 April 2017, 13:49

    Oh, I also have the USA Canada and Mexico map, v975.7772, if that makes any difference.

    Tony F
  • B .E .R

    You can see here how much reputation B .E .R has received from other members.

    Apprentice Traveler
    Replies: 2

    4 April 2017, 03:19

    I to am having the same problem with the 400 rider after a up date no maps nothing how do you get the oceania map that seem to fix every thing i realy nead it for our up coming AGM next month HELP
  • MikkoKMikkoK

    You can see here how much reputation MikkoK has received from other members.

    Community Manager
    Replies: 15297
    Expert (Multi-sport)

    Expert (Multi-sport)

    Expert (Android App)

    Expert (Android App)

    Expert (iPhone App)

    Expert (iPhone App)

    Expert (RIDER)

    Expert (RIDER)

    Expert (Car navigation)

    Expert (Car navigation)

    Expert (Golfer)

    Expert (Golfer)

    Expert (Runner)

    Expert (Runner)

    4 April 2017, 09:43

    Hi duckaroo, thefathippy and B.E.R,

    Welcome to the Community!

    I've assigned the Oceania map to your accounts and you can now install it with MyDrive Connect :D

    Cheers, Mikko
    Help others identify useful content: - Did someone answer your question? Click Mark as Solution - Did someone post something helpful? Click the kudos button - Need help with your TomTom device? Add details about the TomTom device to your post: Device name, Application- and Map version. Check our support videos at tomtom.com/videosupport
  • B .E .R

    You can see here how much reputation B .E .R has received from other members.

    Apprentice Traveler
    Replies: 2

    4 April 2017, 09:48

    Thank Mikkok for the quick action I download it to night B.E.R
Jump to top

Reply to this post

Uploading in progress:
0%
Browse
Add
If the URL is correct, a preview will appear here. It can take a few minutes for larger images to show.
  • :D
  • :?
  • :cool:
  • :S
  • :(
  • :@
  • :$
  • :8
  • :)
  • :P
  • ;)
View mobile version
Powered by Insided