New v4.1.5 of MyDrive Connect available for download


Userlevel 4
Badge +6
  • Retired Community Manager
  • 16813 replies
Hi all,

We've just released a new version of MyDrive Connect and it's available for download at http://tomtom.com/getstarted.

What's new?


Version numbers:
Windows: 4.1.5.3181
MacOS: 4.1.5.3239

This release replaces the public beta version released earlier to address device connection issues. You'll get this offered whether you're running the public beta or previous production version.

Drive safe! 😃

Cheers, Mikko

22 replies

Userlevel 4
@Mikkok

What happened to this screen

I.E. the ability to change the 'Web connection port'
Userlevel 4
Badge +6
Hi Niall,

Thanks for flagging this!

We'll look into it. I'll post back here as soon as I learn more about this.

Cheers, Mikko
Userlevel 4
Badge +6
Hi Niall,

I got a confirmation that this was indeed an intended change. There was a change in this latest version due to which the port option is no longer needed.

Cheers, Mikko
There is a problem with your new my drive connect. It cleaned out my tomtom 6000 of any map - and will not install the alleged new one (which is listed as in need of repair). Right now - the connection from the new my drive connect to you is not working. Says either my tomtom is not connected or that you are busy!! I spent 24 hours on this already - and have no functioning tomtom - and in a country where having it is essential!! I also cannot call you - my phone will not allow it; and no answer to my support requests.
Userlevel 4
Badge +6
Hi ccardillo1,

Welcome to the Community!

Looking at our logs it seems that there's been an interruption with the internet connection causing the update to fail. I'd first recommend you to reset your device as advised below and try again.
https://www.youtube.com/watch?v=_Gjlezrj08c


Please, post back here to tell us how you're doing with this so that we can help you further, if needed.

Cheers, Mikko
Userlevel 4
@MikkoK

Is it that MDC does not use a port, or have the tech team decided it will use a predefined port that a user cannot change, if so what is the port number?
No that is not the problem - as I have reset the device. I even restored the old mydrive, and still nada. Apparently, you wiped my go 6000 clean - it has no data at all. I tried again to download (after doing this all night) - which it has been running now for over three hours - and it is only at 25% complete. The percentage fluctuates up (even reached 50% once!!) and down, but never completes - and then finally quits.
wow - I think you did something - my 6000 is updated and ready to go! If you did - much thanks!
Userlevel 4
Badge +6
Hi ccardillo1,

I'm glad to hear you got it sorted! 😃

It wasn't anything I did as there's nothing we can do from our end to help with customers' internet connection issues. Often trying again another time helps 😃 For more MyDrive Connect troubleshooting tips, please see this FAQ.

@ Niall: I don't know much of about this but I'll try to find out. We'll of course be monitoring for connection related feedback to see what the impact of this release is.

Cheers, Mikko
I'm still having trouble connecting my GO 40 to my computer.
I've reinstalled, cleared cookies. reset the device, restarted the computer ... still no joy.
What do i do next please?
Userlevel 4
Badge +6
Hi Cinders2001,

Something seems to be blocking the connection to our server as there are no error messages in our logs and last connection on the 11th. I'd recommend you to reset your device once more as advised below and connect it to a different USB port on your computer.
https://www.youtube.com/watch?v=_Gjlezrj08c


See also the FAQ I linked to above for more troubleshooting tips.

Cheers, Mikko
This is not a new problem, it happens almost every time. It takes days, and lots of luck to get a full download.
Since download of the latest version of MyDrive Connect (for Mac), over a week ago, there have been no updates for GPSQuickFix or UK Speed Cameras (this has not expired).
The only update which is offered every time I Log in is for Voice Mandy v2. This was previously uninstalled along other unwanted Voices.
Just done the same for me, 2 hour wait now it's wiped by 6000... very unhappy
I have been trying to update my TT Rider 400 for a few days via both Mac and PC.
MyDrive just won't add the device, same darn "update failed, try again" message over and over.
Watching the network traffic I see traffic communicating with
sa.services.tomtom.com
pnd.services.tomtom.com
regpnd.services.tomtom.com
but not much is comming in.

Please make some alternative update procedure available, this just isn't cutting it.
Userlevel 4
Support to advise:

Nederland (Holland)
020 850 1007
Maandag t/m vrijdag van 9.00 tot 17:30
Not able to update maps now with the new MyDrive Connect. I'd like to install the 9.9 maps, but I don't have enough space unless I remove the old maps...but I'm required to have a map set installed so I'm into a Chicken and egg situation here. What's the deal? The old version made it easy to update the device, but not so with this new version. OS X Sierra newest version of MyDrive Connect.
And randomly it worked, but not even remotely using the aforementioned method.
Userlevel 4
Ask support to help:

United States
877-757-7137
Monday - Friday: 9:00 a.m. to 8:00 p.m. EST
Saturday: 10:00 a.m. to 6:00 p.m EST
I know this has come up before but I am so frustrated! My laptop loses its internet connection every few minutes when I open MyDrive Connect that I am unable to update my Rider 40. I've tried deleting the old My Drive and have loaded the current version, but I'm not getting any improvement. When reconnected, I get the following messages: "Ethernet 3 doesn't have a valid IP configuration - detected" " The default gateway is not available - fixed"
This has been going on so long. Please can you help?
Userlevel 4
@navigator1946

See https://en.discussions.tomtom.com/mydrive-connect-apps-474/how-to-stop-your-device-from-killing-your-windows-wifi-network-connection-990415
Thanks for that. Here is my reply to a similar comment several months ago.....

"Thanks for the response. I am using an ethernet cable and I have wi-fi turned off. I would appreciate your further assistance. This problem only occurred after updated MyDrive loaded recently. Previously no problems."

Same problem still occurs.

PS I am not computer-literate so I don't understand some of the computer language used on here!

Reply