Solved

MyDrive doesn't update my Go 5000/5100


I have a GO 5100 and had the bad inspiration to update it today. I've upgraded to the latest MyDrive 4.1.6.3253 and there were some updates to do to the map + software. For one reason or another, the map update is continuously failing and app seems stuck on the screen with "Waiting for your device".
I reinstalled MyDrive, logged out/in, changed the cable, nothing is changing.
I can see in the HOME3\cache folder that the map is downloaded (I tried multiple versions of Europe with/without buildings, both are there) but seems like it's not uploaded to the device.
What can be done? As the PND is completely useless right now.

later edit: would be nice to have the possibility to download an older MyDrive, which didn't have this problem.
icon

Best answer by morbidel 14 October 2017, 19:38

Hi guys,

Issue got fixed after calling TomTom support. They provided me a list of potential issues, and the culprit were some ports which were used by another app. Be sure you have ports 80, 443, 3128, 3129 and 4000 free.

Cheers

View original comment

7 replies

Userlevel 4
Badge +3
Hi morbidel

Could you disconnect the device, do a soft reset and then connect the device again.

If that does not help then please report this to the customer service as they will be in a better position to investigate this further.

Regards
Vikram
Hi,

I tried that already as I knew about the soft reset (I worked at TomTom PND few years ago), but it doesn't help.
Before spending time on the phone about this, can I find an older MyDrive version available somewhere?
Thanks,
Stefan
I have the same problem with updating my Start 20. I get the "Waiting for your device" notification. I kept resetting and nothing changed. So I then just left the device for a couple of hours, and again, nothing changed. I have also just downloaded the latest version of MyDrive Connect. This has to be a major flaw in the TomTom software, as there are literally dozens of complaints about the same situation. Come on TomTom, you`ve got our money, so how about fixing this ongoing flaw. I never had any problems with my two previous TomTom devices.
Userlevel 4
Try a drum reset on the unit by holding the power button about 20 seconds till you hear the drum sounds. Then see if you are successful.

Support:

United Kingdom
02079 490 134
Monday - Friday: 9:00 a.m. to 5:30 p.m.
Hi,
I tried that, it was already suggested by VikramK. It didn't help. Do you know where I can find some older MyDrive versions that I can try?
Cheers,
Stefan
Userlevel 4
Call support:
Suisse (Switzerland)
0844000091
du lundi au vendredi de 09h00 à 17h30
Hi guys,

Issue got fixed after calling TomTom support. They provided me a list of potential issues, and the culprit were some ports which were used by another app. Be sure you have ports 80, 443, 3128, 3129 and 4000 free.

Cheers

Reply