Question

Waiting for device-MyDrive Connect


Tomtom 5000
Anyone else having problems updating with Mydrive connect.
Downloading the updates working ok but then stuck on "waiting for your device".
Have done soft reset and have cleared cache in Mydrive,but still nothing.
Any suggestions please.

11 replies

Userlevel 7
Maybe support can help:
United Kingdom
02079 490 134
Monday - Friday: 9:00 a.m. to 5:30 p.m.
Userlevel 7
Badge +2
Hi
@couriervanman
On the rare occasions that I have problems with MyDrive connect, I delete the "HOME3" folder in MyDrive Connect...
If you have installed MyDrive Connect to the default location using Windows 10
It's located here... C:\Users\"Your Computers Name goes here"\AppData\Local\TomTom > HOME3
This not only removes the Cache but the Prefs.ini, cookies.ini, Logs and Configuration.xml
A new Home3 Folder and its contents are created fresh the next time you use MyDrive Connect
___________________________

Method…..
1. Disconnecting the SatNav from the PC and resetting it by holding down the off button for 20 secs until you hear the ‘drumbeat’ release the button
2. Opening ‘Run’ on the PC (click on the windows symbol bottom left – type ‘run’ in the search box – open ‘run’.
3, type into the ‘run’ box %localappdata% and press enter.
4. Find the TOMTOM folder in the window that will have now opened and open it.
5. Delete the Home3 file that is most likely corrupted and close all windows.
6. Turn on the SatNav and reconnect it to the PC and open ‘My Drive Connect’ and all should be well

ATB YFM
Thanks both,
I have already tried the deleting home3 method,but still no good.
I have had no problems updating the 5000 for the first 2 years,only seems the last 4 or 5 weeks which is strange.Have not changed anything on my windows 7 laptop regarding anti-virus etc.
Any other suggestions anyone,i'm on the road everyday and am getting a bit paranoid without the most recent camera updates.I'm no racer but for peace of mind i would like to get it sorted.
I HAVE HAD THE SAME PROBLEM WITH DOWNLOADS. DURING THE LAST TWO DOWNLOADS I UNPLUGGED TO CORD TO COMPUTER IN THE MIDDLE OF DOWNLOAD,PLUGGED IT BACK IN RIGHT AWAY AND BINGO IT STARTED THE ACTUAL DOWNLOAD. NOT SURE IF IT WILL WORK FOR ALL HOWEVER IT WORKED FOR ME. IT SHOULD NOT DO THIS HOWEVER UNTIL SOMEONE IT TECH CAN FIGURE THIS OUT I'M DOING IT THIS WAY.
Well,i have finally found the answer for this problem.It turned out to be Bitdefender free version anti-virus that was preventing the update.I hadn't taken it into consideration as i had been using it for 2 years without a problem.I can only think that in the last month or so they have put a mark against Mydrive Connect in an update,and you can't add an exception for it in the free version.A lot of people use this top-rated Anti-virus so i would not be the only one having problems.
I have now installed Avast free and the Tomtom update is working fine.
Many thanks for all replies.
Userlevel 7
Badge +2
Hi
@couriervanman
We must be living in a parallel universe ☺
I used to run Bitdefender and yes the firewall is a right royal PITA
I would set-up MyDrive Connect in the Bitdefender Whitelist... When I logged out MyDrive and logged back in... Bitdefender would decide to remove MyDrive Connect from the whitelist and block access through the firewall
Bitdefender Support even sent a fix to install but nothing worked for me
Like you I now use Avast and have not had a problem with the firewall

ATB YFM
I'm having similar problems with my 5000. It's been a bit hit and miss getting map updates in the last two or three times, but a couple of restarts seemed to nudge it through. This time I have just bought a new speed cam update. Trying to install it left me stuck in "waiting for device". After a few restarts I left it for 24 hours, no change. I deleted HOME3 and now it's stuck on "checking" currently for 30 minutes.

It is unacceptable, this should be a relatively simply data load that other apps manage in a trice. I think I'll have to ask for my money back on the speed cam data and move on. TomTom seems to not be on top of this if it's a continuing problem for years.
Userlevel 1
I just got off the phone with support as I was having the same issue. They told me there is a server problem which they hope to have sorted by the end of the day. Cost me nearly 20 mins of my mobile call minutes allowance to find that out. 😂
Thanks for taking one for the team there. I'll wait a bit then. But why a server problem back at their place shows as a local connection issue to the device, I don't know. Perhaps it's just bad software,

Anyway, I'll leave it until tomorrow. 😴
Userlevel 1
Yesterday I was getting "Server Busy" but today another update appeared and it was "Waiting for Device", I too am not convinced. Below is an extract from their follow up email :

"I am sorry to hear that you have experienced an issue while updating your device.

There is an ongoing server outage, this is an issue that we are aware of and urgently working to resolve."
Userlevel 7
Badge +3
Please see here:

https://en.discussions.tomtom.com/travel-lounge-154/problems-with-mydrive-connect-and-accessing-tomtom-services-on-the-device-1041706

Reply

    Cookies

    At TomTom, we're all about helping you get around. That's why we use cookies to improve our sites, to offer information based on your interests and to interact with social media. If you're OK with this, you can continue using our sites. Allow Learn more or manage preferences

    Allow Cookie settings