Question

Our address is not shown correctly on the map


Hello,
Our address is not shown correctly on the map. Because of that people can’t find our address. Our post can’t be deliverd. This is very disturbing. How can I change it or how can I help you to make your map and our address correct in your map.
I hoop somebody can help me.

8 replies

Userlevel 7
@Lost adres

Contact Customer Services to sort out your address details on their system

🇳🇱 Nederland (Holland)
020 850 1007
Maandag t/m vrijdag van 9.00 tot 17:30
Userlevel 7
Badge
Next to that, you can also report the issue using the online Map Share Reporter tool.
I have looked there but it is correctly on the map but everyone tell’s us that they are send to an other street nearby. Most postdelivery workers can’t find number 10 on that street because it dous not exist. Than they give up.
Tomotow I try to call the costumers service. Thank you for your reaction.
Userlevel 7
Badge
Hi, do you have a TT device yourself? If so, could you check if you can find the right address using that device? If not, you can send me the address and I can check on the device I have here if you want.
Hello,

My TT device is very old and because of that I didden’t check it. My address is: Oude sluis 10 6051EA Maasbracht in the Netherlands. Thank you for your help.
Userlevel 6
Badge +3

Yes that is the place I live. Maybey the old device only send people to the wrong adress. Or the device only talks people to the wrong address. I will try with my old device when I’m home. Thank you for your help
Userlevel 7
Badge
Thanks. I checked as well on the two latest map versions and both show the correct location. So probably indeed the not updated devices of those people that still show the wrong location.

Reply

    Cookies

    At TomTom, we're all about helping you get around. That's why we use cookies to improve our sites, to offer information based on your interests and to interact with social media. If you're OK with this, you can continue using our sites. Allow Learn more or manage preferences

    Allow