Question

Ease frozen


My ease displayed the warning that the maps were xx months old and to get the free user updates (or somethiing like that.)  I downladed and installed the "home" program, plugged the Ease in and waited. And waited. The icon indicating that there was no device connected remained.  Tried reinstalling, rebooting, etc. Still no device.  I unplugged the ease. It locked. Nothing would power it down. Could hold in the power button for a minute.  Finally the battery died.  I recharged it. Now it won't run at all. Just the Tomtom logo appears. Can't get past that - and the software still indicates that there is no device connected.
This topic has been closed for comments

8 replies

Userlevel 4
Badge
ONce the battery is charged (min 2 hr gps off) the correct way to connect to Home, is:

1. Plug gps (gps turned off) in to computer USB on computer, not the monitor, not the keyboard, and not a USB hub.

2. Turn on gps, tap yes when asked if want to connect to computer. It should update automatically, though you will have to be logged on to TT Home.

3. When updates are complete, you must safely disconnect (Device/Disconnect) and wait for the message it is "safe to disconnect".

Not following the above steps may have resulting in your current problem. Your may be able to reconnect now by plugging in as in  step one, then in step two while turning it on hold the on button till you hear a double drum roll.

Post back your result.
That's exactly wat I did. I ran "Home", plugged in the GPS and turned it on.  I was asked if I wanted to connect to the computer - I let it.  "Home" never detected the GPS. Windows 7 gave a warning that the driver for an "Unknown USB device was not installed" . I closed and ran the software ("Home") several times. It never detected the GPS.

So I removed the GPS - what else could I do? Since the software never found the GPS, it never did any updates. SO now the GPS is a paperweight.
Also, your instructions simply stat to connect the GPS to the computer. They do not mention not using hubs, etc.

So what you're saying is that once the GPS is connected, if the software can't find the unit, either I leave it connected forever, or disconnect the GPS and trash it?

Wow. Great design.
Userlevel 4
Badge
Sorry if you took my reply to your post as offensive.

Here is what I said:

1. Plug gps (gps turned off) in to computer USB on computer, not the monitor, not the keyboard, and not a USB hub.

So where did I not warn of connecting to a USB hub? Does that mean you were connected to a USB hub?

Since your post did not say exactly what you did I gave the correct procedure just in case. All USB connected devices should be properly disconnected, if not through TT Home, then by using the green arrow on the bottom right of your computer.

My question now is will it connect and be recognized by holding the power button till the drum roll?

Just so you understand; I am a TomTom user, just like you. I am a volunteer.
Userlevel 4
Badge
Here are more suggestions to get your Start running again. Once you click on this link move down to the instructions for "Other Devices". This will not work if you are still unable to get TT Home to recognize your Start, but give it a try. http://us.support.tomtom.com/app/answers/detail/a_id/9091" target="_blank
The instructions for the software do not mention a USB hub, keyboard, etc. The instructions the software displays are to connect the GPS. No restrictions are given by the software. I was not saying YOU did not give the correct procedure - if that is the required procedure, the software should state that.  Being informed of this AFTER the fact is not helpful. Yes I connected it to a powered hub - like 90% of the PC users out there, I use a USB hub. There was no warning about not using a hub in the instructions. I have several other GPS units from other manufacturers. A hub is no problem. My smart phone has no problem with the hub. None of my devices has a problem updating via a hub. Just the TomTom.

When the drum roll occurs the GPS locks - I Can't do anything.  The software never found the device. The computer simply gave an error along the lines of a driver could not be found for the connected device.

There was nothing to disconnect - the device was never discovered.  So simply plugging in the device, pressing the "connect" option on the GPS then unplugging it, locked the GPS up. There was no way of getting rid of the "don't unplug" warning. The software did not find the GPS. I left it connected for hours. I rebooted the PC. I reran the software numerous times. The warning never went away.

After two reboots and hours of connection, I unplugged the GPS from my computer.

It remains locked.  If I charge it, then turn on. I get the drum roll and nothing else.  It will not turn off after that.  All I can do is wait until the battery dies.
All the solutions assume the GPS is detected by the software. It is not - the software can't find the GPS unit.
Userlevel 4
Badge
I realize the instructions are not always clear or complete; but let's try again.

Make sure your Ease is fully charged.

To get a reliable connection to your computer you should connect to a USB port in the back of your computer. Once you find it is connected, when everything is fixed, you can then try a front port.

Connect to your computer and reset your Ease through the pinhole reset on the bottom: http://us.support.tomtom.com/app/answers/detail/a_id/7134/p/141%2C2480" target="_blank

This should reconnect your Start.

What kind of computer are you connecting to? If you still can not connect you should check your USB port to make sure it is enabled.

You can check this (I only can advise on Windows) by going to Control Panel (need to be signed in as Administrator to make changes), then System, then Hardware, then Device Manager, then go the the bottom of the list to Universal Serial Bus Controllers, open the list with the '+' then just below USB Composite Device you will either see USB Mass Storage Device (your XXL) or a USB Root Hub. If all you see is the later, right click it, left click Properties, and at the bottom will be Device usage. Check the window, it probably says Disabled. Click the right hand arrow to set it to Enabled, click OK and exit. Now try  to connect.

Once connected you can try to restore your device if it still will not work.

Use this link if you need to restore your Ease. Once you click on this link move down to the instructions for "Other Devices". http://us.support.tomtom.com/app/answers/detail/a_id/9091