Question: data.chk deletion error

live, data.chk, go540, deletion, error,

burkflash Author

You can see here how much reputation burkflash has received from other members.

Apprentice Traveler
Replies: 2

12 April 2011, 00:05

I can access TomTom Home.  Load updates, Click Update and Install button.  Complete download.  Then on Install to Hard Drive, I encounter an error message: Could not delete "F:/data.chk".  I have tried going to My Computer to F drive, locating TomTom Home, then deleting data.chk files but this does not solve my problem on Install to Hard Drive.  Any suggestions?  Thank you.
  • dhn

    You can see here how much reputation dhn has received from other members.

    Paragon Vanguard
    Replies: 26898

    12 April 2011, 01:16

    Yes. DON'T delete that file or the tomtom will not function. The extension of .chk in linux means something entirely different than in the Woindows world where .chk is normally associated with a recovered file fragment.

    That file is needed.
  • burkflash Author

    You can see here how much reputation burkflash has received from other members.

    Apprentice Traveler
    Replies: 2

    12 April 2011, 01:29

    The installation process tries to delete the data.chk file but cannot.  When I look via windows, the data.chk file has no volume.  Is there a workaround?  I understand that I have been confusing Windows and Linux.

    Thank you.
  • mvl
    Revered Voyager
    Replies: 1919

    14 April 2011, 04:36

    run a chkdsk /f on the Tomtom drive and see if that helps.
    I am a moderator at tomtomforums.com, an independent community of Tomtom customers. I am a Tomtom customer, not an employee. I have 8 years experience with Tomtom PNDs, and just started using a fitness watch.
  • JohnKennedy

    You can see here how much reputation JohnKennedy has received from other members.

    Outstanding Explorer
    Replies: 22

    9 July 2011, 07:21

    I had this problem after changing my computer the data chk file stopped the installation every time I tried all the tries, scanning to fix errors, deleting everything using tomtom home, full format of drive, reinstalling tomtom home and getting advice from support who told me to do everything I had already tried and still no good. 

    I was about ready to bin my device as it was now totally useless believing there was a fatal memory problem in the drive. When I realized my problem only started after trying to update on the new computer so I loaded tomtom home onto my daughters laptop and to my amazement it worked first time the application and map loaded and work fine even the live services all operating correctly. 

    The only things missing are the start up splash image which I am sure can be replaced and the UK postcodes are missing I have had that one before but cannot remember how to fix just now.

    To summaries the 'data.chk deletion error' was not a device failure it was my computer causing the problem I assume some security setting probably but don't know what or how to correct it  

    My device is a GO 540 live


    Just found this tool and although my problem was sorted  thought it might have helped if found earlier 

  • NewUser2012

    You can see here how much reputation NewUser2012 has received from other members.

    Apprentice Traveler
    Replies: 1

    4 November 2012, 19:25


    I got this same error about deleting f:data.chk followed by errors for writing chk files and even more errors for copying other file types. I was about to give up when I noticed that the update seemed to move a bit further along after I manually intervened and dealt with each problem file. However, that was taking all day!

    I'm using a new Windows 7 laptop and a USB 3.0 port with TomTom XL IQ Routes. Finally, I tried switching to the only USB 2.0 port on my new laptop and all of a sudden the update completed!  To be sure it wasn't due to blind luck I repeated the process again until the TomTom Home 2 interface reported that there were no new updates available for my device because it was up to date. So, after I switched USB ports the problems with deleting, moving and copying files all went away. Could it be that the TomTom cannot keep pace with a USB 3.0 port? I'm not sure of this will work for you but it did the trick for me.

    FYI: Some TomToms don't have a reset button and can be reset by holding down the power button until you hear a drum roll sound.
  • vette10

    You can see here how much reputation vette10 has received from other members.

    Apprentice Traveler
    Replies: 2

    5 November 2014, 16:13

    That worked!!!  I guess the unit is blind to USB3!!

    Even though it continued to install, it still won't start, I keep getting the "lawyer" screen!!!!
View mobile version
Powered by Insided