Home

Pro 5150 not updating maps

Tags:
maps, update, traffic,

BennettS Author

You can see here how much reputation BennettS has received from other members.

Master Explorer
Replies: 6

19 March 2017, 13:02

I have a Pro5150 Truckers satnav and recently connected it to MyDrive to update the maps. After 2hrs plus, it said it was up to date, but when I tried to find an address, it couldn't locate it. I also have a Rider 400 and put the postcode in that one and it found it.

I have also got a message on the Pro5150 which reads 'Traffic - An error occurred on the TomTom server. Please try again' So I am not getting details of any traffic problems. Could you advise
  • Niall

    You can see here how much reputation Niall has received from other members.

    Exalted Vanguard
    Replies: 5195
    Expert (Car navigation)

    Expert (Car navigation)

    Expert (RIDER)

    Expert (RIDER)

    19 March 2017, 13:49

    @BennettS

    From the general chat on this user forum, it seems as if the European Traffic server is down and has been since late Friday afternoon.

    With regards to your map update, did you do a soft reset after the installation? As this often helps to get the file system aligned
    Help others identify useful content :- - If I posted something that was helpful? Click the Like button - If I answered your question? Click Mark as Solution
  • BennettS Author

    You can see here how much reputation BennettS has received from other members.

    Master Explorer
    Replies: 6

    19 March 2017, 14:01

    Thanks for that.
    No I didn't - how would I do that?
  • Niall

    You can see here how much reputation Niall has received from other members.

    Exalted Vanguard
    Replies: 5195
    Expert (Car navigation)

    Expert (Car navigation)

    Expert (RIDER)

    Expert (RIDER)

    19 March 2017, 14:08

    @BennettS

    After each up date to do a soft reset, you will loose nothing, it is like rebooting your computer and reloads all the new files from an update.

    A soft reset :- with your device charged for at least 2Hrs "OR" have the device plugged into a power supply; press and hold your on/off button until you hear a drum-roll sound (or the TomTom hands symbol appears) then release the on/off button.
    Help others identify useful content :- - If I posted something that was helpful? Click the Like button - If I answered your question? Click Mark as Solution
  • BennettS Author

    You can see here how much reputation BennettS has received from other members.

    Master Explorer
    Replies: 6

    20 March 2017, 19:13

    Hi - Have tried this, and unfortunately it hasn't made any difference.
  • Niall Modbreak

    You can see here how much reputation Niall has received from other members.

    Exalted Vanguard
    Replies: 5195
    Expert (Car navigation)

    Expert (Car navigation)

    Expert (RIDER)

    Expert (RIDER)

    20 March 2017, 20:11

    @BennettS

    In that case contact Customer Services to sort this out and maybe rest your device's SIM

    CS United Kingdom
    02079 490 134
    Monday - Friday: 9:00 a.m. to 5:30 p.m.
    Help others identify useful content :- - If I posted something that was helpful? Click the Like button - If I answered your question? Click Mark as Solution
View mobile version
Powered by Insided