Trouble Formatting Memory Card on Device GO 500


Hello,

I would really appreciate some help. I've recently purchased a SD card for my TomTom Go 500 Sat Nav (it is the correct card for the device). The first time I inserted the card and connected it to my laptop, it said "would you like to format the memory card?", to which I clicked "yes". Following this, it said on the device screen that it was processing and that it would take several minutes. Fast forward around 30 minutes to an hour, and it was still saying the same thing. I assumed it just wasn't working, so I unplugged the device from my laptop. The result is that now it does, well, nothing. It's not recognising the SD card and it no longer pops up saying if I wish to format it. Now i'm a bit stuck as to what I should do next. I've tried turning it off and reinserting the card when the maps come on the screen but nothing seems to work. It simply isn't registering the SD card, meaning that I cannot download new maps for my device.

Any advice would be greatly appreciated.

Many thanks,

Holly

1 reply

Userlevel 7
Try formatting the card in a card reader as FAT32. Don't use quickformat. Then insert card into device and see whether process proceeds any better.

Also, be aware some card brands aren't as robust as others. SanDisk is a good choice for reliability.

Reply

    Cookies

    At TomTom, we're all about helping you get around. That's why we use cookies to improve our sites, to offer information based on your interests and to interact with social media. If you're OK with this, you can continue using our sites. Allow Learn more or manage preferences

    Allow Cookie settings