GO 5100 window mount not charging

Userlevel 2
My Go5100 window mount (the one with the row of male connectors that slot into the female connectors on the bottom of the Go5100), has started to not supply power/charge for some reason. I noticed the other day that the unit would say 'Low Battery' and turn off. I disconnected the window mount from the USB cable and plugged it directly into the Go5100 and all was ok, so it looks like it's the window mount is at fault, or could it be the female connectors on the Go5100? I've looked at both the connectors and they seem ok to the naked eye. Any ideas? And if it IS the window mount, where can I buy another one? Some of the ones on Ebay look a bit suspect............

2 replies

I am having the same fault after couple of years...
I keep getting the response that the power can't run and charge at the same time...
But I use the same cig adapter with 2 USB sockets - one supplies 5v 1.2a (sufficient for the device so TT say) and the other 5v 2.1a - which it is connected to.

In my company car no issues but moved to a hire car and for the past two weeks it has switched off 3 times!

So either a fault with cradle or TT issue with new update software not supporting as it should.

AND you'll find nobody seems to see this.
Userlevel 2
Looks like you were right @DJSheridan
Strange how no one from TT ever reads these, or if they do, they never respond........I've now bought a new car, and it does the same thing in that one too. I've tried cleaning the various electrical contacts on the cradle with a Q tip and alchohol, but to no avail. I don't want to buy a new cradle (not that you seem to be able to buy one anyway) only for the same thing to happen. Wish there was an easy way of testing the contacts on it.............



    At TomTom, we're all about helping you get around. That's why we use cookies to improve our sites, to offer information based on your interests and to interact with social media. If you're OK with this, you can continue using our sites. Allow Learn more or manage preferences

    Allow Cookie settings